poj1129_Channel Allocation

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11194 Accepted: 5744

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.  

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.  

Following the number of repeaters is a list of adjacency relationships. Each line has the form:  

A:BCDH  

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form  

A:  

The repeaters are listed in alphabetical order.  

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.  

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

分析:图着色问题,邻接表建图加dfs。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>


using namespace std;

typedef struct  Node
{
	int num;
	struct Node *next;
}Node;

struct Mgrage
{
	Node *head;
};

Mgrage map[30];
int x[30];
int n, cornum;

void init()//图的初始化
{
	for (int i = 0; i < 30; i++)
		map[i].head = NULL;
}

void insert(char ch, char c)//邻接表建图
{
	int k = ch - 'A';
	int l = c - 'A';
	Node *p, *q;
	p = (Node *) malloc(sizeof(Node));
	p->num = l;
	p->next = NULL;
	q = map[k].head;
	if (q == NULL)
		map[k].head = p;
	else 
	{
		while (q->next != NULL)
			q = q->next;
		q->next = p;
	}
}

bool ok(int num, int col)//检查颜色是否可用
{
	Node *p;
	p = map[num].head;
	while (p)
	{
		if (x[p->num] == col)
			return 0;
		p = p->next;
	}
	return 1;
}

bool  dfs(int num, int sum)
{
	if (sum == n)
		return 1;
    for (int i = 1; i <= cornum; i++)
	{
		if (ok(num, i))
		{
			x[num] = i;
			if (dfs(num + 1, sum + 1))
				return 1;
			x[num] = 0;
		}
	}
	return 0;
}

int main()
{
	while (scanf("%d", &n) == 1 && n != 0)
	{
		getchar();
		init();
		memset(x, 0, sizeof(x));
		int num = n;
		while (num--)
		{
			char a[35] = {0};
			gets(a);
			int len = strlen(a);
			int i;
			for (i = 2; i < len; i++)
				insert(a[0], a[i]);
		}
		cornum = 1;//记录最少的颜色总数
		while (!dfs(0, 0))
		{
			++cornum;
			memset(x, 0, sizeof(x));
		}
		if (cornum == 1)
			printf("1 channel needed.\n");
		else
			printf("%d channels needed.\n", cornum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值