ZOJ 1151 Word Reversal反转单词 (string字符串处理)

链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=151

For each list of words, output a line with each word reversed without changing the order of the words.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.

Output

For each test case, print the output on one line.

Sample Input

1

3
I am happy today
To be or not to be
I want to win the practice contest

Sample Output

I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc


翻译:
对于一串单词,直接把他们输出在一行上,要把每个单词反转,但每个单词的位置不要改变;
本程序包含多组测试数据;
输入数据的第一行是一个整数N,然后是一空行,后面跟着N个数据块,每个数据块的格式在程序描述中说明了,数据块中有一空行。
输出格式由N个输出块组成,每个输出块之间有一空行;

输入描述:
现给你多组测试数据,第一行是一个正整数,表示接下来测试数据的组数,每组测试占一行,包含一串单词,中间用一个空格隔开,每个单词仅包含大写和小写字母;
输出描述:
每组测试数据都打印在一行上;

代码:

#include <iostream>
#include <string>
#include <cstdio>
#include <algorithm>
using namespace std;

string s, t;
int n, cas, flag = 0;
char ss[1000];

int main()
{
    cin >> cas;
    while(cas--) {
        scanf("%d", &n);
        getchar();
        while(n--) {
            cin.getline(ss, 1000);
            s = ss;
            flag = 0;
            t.clear();
            for(int i=0; i<s.size(); i++) {
                if(s[i] != ' ' && i <= s.size()-1) {
                    t += s[i];
                }else {
                    reverse(t.begin(), t.end());
                    if(flag) cout << " ";
                    cout << t;
                    flag = 1;
                    t.clear();
                }
            }
            reverse(t.begin(), t.end());
            cout << " " << t << endl;
        }
        if(cas) cout << endl;
    }
    return 0;
}


反转单词的另一种变形,思路都是差不多,一般在笔试面试题中经常会遇到,而且会直接让你写出代码,以下是小灰灰在腾讯面试的时候碰到的一道题:
在一个缓冲区中(发送或者接受缓冲区),在你接收到的字符文本中,你如何实现让该文本内的单词序列反向有序输出,请用代码实现!!!
Sample Input:
I love The Vampire Diaries!
I also love           (前面多个空格)Damon!!!
 
Sample Output:
Diaries! Vampire The love I
Damon!!! love also I
 
代码实现如下:
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cstdlib>
#include <algorithm>    //使用reverse需要的头文件
#define MAXN 10010
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

int main()
{
    freopen("data_in.txt", "r", stdin);   //文件输入输出流重定向
    freopen("data_out.txt", "w", stdout);
    string str;
    while(getline(cin, str)) {   //每次读入一行文本
        int len = str.length();
        int flag = 0;
        string s;
        s.clear();     //使用前记得清空
        for(int i=len-1; i>=0; i--) {
            if(str[i]!=' ') {
                s += str[i];
            }else {
                if(s.empty()) continue;    //判断字符串是否为空,去掉单词之间多余的空格
                reverse(s.begin(), s.end());   //反转
                if(flag) cout << " " << s;   //控制输出格式
                else cout << s;
                flag = 1;
                s.clear();    //每次清空容器
            }
        }
        reverse(s.begin(), s.end());   //第一个单词放在最后输出
        cout << " " << s << endl;
    }
    fclose(stdin);
    fclose(stdout);
    return 0;
}

 
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值