Word Reversal

Word Reversal

Description
For each list of words, output a line with each word reversed without changing the order of the words.

Input
The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words separated by one space, and each word contains only uppercase and lowercase letters.

Output
For each test case, print the output on one line.

Sample Input
3
I am happy today
To be or not to be
I want to win the practice contest

Sample Output
I ma yppah yadot
oT eb ro ton ot eb
I tnaw ot niw eht ecitcarp tsetnoc

题意:首先输入一个整数确定下面所需要输入的行数;再分别对下面输入每一行进行单词倒序。

#include<stdio.h>
#include<string.h>
int main()
{
    int n,k=0,l,i,j;
    char s[1000],a[1000];
    scanf("%d",&n);
    getchar();
    while(n--)
    {
        gets(s);
        l=strlen(s);
        j=0;
        for(i=0;i<=l;i++)
        {
            if(s[i]!=' '&&s[i]!='\0')
                a[j++]=s[i];
            else
            {
                for(k=j-1;k>=0;k--)
                    printf("%c",a[k]);
                if(s[i]!='\0')
                    printf(" ");
                j=0;
            }
          }
        printf("\n");
    }
    return 0;
}

【收获:scanf不能接受空格,Tab,回车等,而gets可以;scanf在遇到以上这几种情况时会自动在后面添加空字符’\0’,但不会因此清空缓冲区(缓冲区中空格//Tab//回车依旧存在),而gets会接受回车之前的所有字符并最后用’\0’取代’\n’,并且回车键并不会留在缓冲区】

即:题中
scanf("%d",&n); getchar(); getchar()是为了取走缓冲区里没有被清空的回车,以及防止下面的gets()单独取走回车独立成串。
【下面的gets()后不能加getchar()是因为:每一次gets完都不会有多余的回车存在,用了则会使所取的字符串少一个字符】

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值