HDU 1016 Prime Ring Problem(经典DFS )

题目链接:    http://acm.hdu.edu.cn/showproblem.php?pid=1016


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source


代码如下:

#include<cstdio>
#include<iostream>
#include<cmath>
const int MAX=100;
int prim[MAX],chucun[MAX],mark[MAX];
int n,count;
using namespace std;
bool prime(double x)
{
    int i;
    for(i=2;i<=sqrt(x);i++)
    {
        if(int(x)%i==0)
            return false;
    }
    return true;
}
void DFS(int x)
{
    if(x==n&&(prime(double(1+chucun[x-1]))))//深搜到结束条件(第一个数字为1,(环)判断最后一个数加1是否为素数)
    {
        for(int i=0;i<x;i++)
        {
            if(i==0)
                printf("%d",chucun[i]);
            else
                printf(" %d",chucun[i]);
        }
        printf("\n");
    }
    else
    {
        for(int i=2;i<=n;i++)
        {
            if(!mark[i] && prime(double(chucun[x-1]+i)))//如果这个数没用过,并且这个数和上一个放到环里的数之和是素数
            {
                mark[i]=1;
                chucun[x]=i;
                DFS(x+1);
                mark[i]=0;//回溯
            }
        }
    }
}
int main()
{
    int i,p=1;
    while(~scanf("%d",&n))
    {
        printf("Case %d:\n",p++);
        chucun[0]=1;
        memset(mark,0,sizeof(mark));
        DFS(1);
        printf("\n");
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值