ZOJ 3810 A Volcanic Island(四色定理模板)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5342


A Volcanic Island

Time Limit: 2 Seconds      Memory Limit: 65536 KB      Special Judge

An underwater volcano has erupted massively in somewhere of the deep Atlantis Ocean. This large eruption led to the birth of a new volcanic island, which had a shape of square. Near the island, there are N countries. All of them have claimed the sovereignty over the island.

After a lot of multilateral negotiation and occasional armed conflicts, the N countries decided to divide the square volcanic island equally. They partitioned the island into N x N small equal-sized square chunks. Each country could get a connected region consists of exact N chunks.

Two chunks A and B are called "connected" if they share an edge, or there exists another chunk C connected with both A and B. A group of chunks are called "connected region" if any two of these chunks are connected.

Every country want a unique region. It means the N regions should be different with each other. Two regions are considered as the same if and only if one can transform into the other by an isometry (a combination of rigid motions, including translation, rotation and reflection).

In a nutshell, your task is to divide a square island with N x N chunks into N connected regions with different shape. You also need to draw a map to color the regions of the map so that no two edge-adjacent regions have the same color. Most of the people in these countries believed that four different colors are enough. So you can mark these regions with at most four colors, red, green, blue and yellow.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is only an integer N (1 <= N <= 100).

Output

For each test case, output a valid map described above. If there is no solution, output "No solution!" instead. Please note that only four colors ('R', 'G', 'B' and 'Y') can be used to drawing the map.

Sample Input
2
2
5
Sample Output
No solution!
YYYGR
YGGGR
YGYYR
BYYYR
BBBBR

Author: ZHOU, Yuchen
Source: The 2014 ACM-ICPC Asia Mudanjiang Regional First Round

题意:

用 n 块面积为 n 的图块拼满一个 n*n 的矩阵图,并且 n 块图只有四种颜色,相邻的图块不能有相同的颜色,任意的两块不能有相同的形状,包括旋转,对称;


注意当n为6 的时候会有相同的块,所以要特判一下;


代码如下:

#include <cstdio>
#include <cstring>

const int MAXN = 117;
char mm[MAXN][MAXN];
char col[2];
int n;

void solve()
{
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < n; j++)
        {
            mm[i][j] = 'B';
        }
    }
    for(int i = 0; i < n; i++)
        mm[0][i] = 'Y';
    for(int i = 0; i < (n-1)/2; i++)
    {
        char c = col[i%2];
        for(int j = i+1; j < n; j++)
        {
            mm[j][i] = c;
        }
        for(int j = 1; j <= i+1; j++)
        {
            mm[j][i+1] = c;
        }
    }
    for(int i = (n-1)/2; i < n-1; i++)
    {
        char c = col[i%2];
        for(int j = i+2; j < n; j++)
        {
            mm[j][i] = c;
        }
        mm[i+2][i+1] = c;
        for(int j = 2; j <= i+2; j++)
        {
            mm[j][i+2] = c;
        }
    }
    for(int i = 0; i < n; i++)
    {
        for(int j = 0; j < n; j++)
        {
            printf("%c",mm[i][j]);
        }
        printf("\n");
    }
}

int main()
{
    col[0] = 'G';
    col[1] = 'R';
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        if(n == 1)
            printf("Y\n");
        else if(n <= 4)
            printf("No solution!\n");
        else if(n == 6)//特判
        {
            printf("YYYYYY\n");
            printf("GGRGRR\n");
            printf("GRRGRB\n");
            printf("GRGGRB\n");
            printf("GRGRRB\n");
            printf("GRGBBB\n");
        }
        else
        {
            solve();
        }
    }
    return 0;
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 3
    评论
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值