HDU 2795 Billboard(线段树)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2795

 

 

 

 

Problem Description

At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

 

 

Input

There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

 

 

Output

For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.

 

 

Sample Input

 

3 5 5 2 4 3 3 3

 

 

Sample Output

 

1 2 1 3 -1

 

 

Author

hhanger@zju

 

 

Source

HDOJ 2009 Summer Exercise(5)

 

 

 

题意:

有一个 h * w 的矩形广告板,现在要在上面贴海报; 

每个海报的大小规格是 1 * w , 要求每个海报要尽量往上并且尽量靠左贴; 

求第 n 个海报的所在的位置;

如果不能再贴海报则输出 -1; 
 
PS: 
我们可以运用线段树来求得区间的最大值; 

我们可以将位置也就是 h 来建树,树中节点存的是当前区间还拥有的最大空间; 

如果左子树的最大值大于 x ,就查询左子树,反之就查询右子树; 

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define lson l, mid, rt<<1
#define rson mid+1, r, rt<<1|1
const int maxn = 200017;
int a[maxn << 2];
int h, w, n;
void pushup(int rt) //把当前结点的信息更新到父结点
{
    a[rt] = max(a[rt<<1], a[rt<<1|1]);
    //a[rt] = a[rt<<1] + a[rt<<1|1];
}
void build(int l, int r, int rt)
{
    if(l == r)
    {
        a[rt] = w;
        return ;
    }
    int mid = (l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
int query(int x, int l, int r, int rt)
{
    if(l == r)
    {
        a[rt]-=x;
        return l;
    }
    int mid = (l+r)>>1;
    int ret = 0;
    if(x <= a[rt<<1])//x小于左子树的最大值
        ret = query(x, lson);
    else
        ret = query(x, rson);
    pushup(rt);
    return ret;
}
int main()
{

    while(~scanf("%d%d%d",&h,&w,&n))
    {
        if(h > n)
        {
            h = n;
        }
        build(1, h, 1);
        int x;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d",&x);
            if(a[1] < x)//最大值都小于x
            {
                printf("-1\n");
                continue;
            }
            int ans = query(x, 1, h, 1);
            printf("%d\n",ans);
        }
    }
    return 0;
}
/*
4 6 6
2
4
3
3
3
5
*/

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值