HDU 2795 Billboard 线段树 java实现

Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.
On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.
Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.
When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.
If there is no valid location for a new announcement, it is not put on the billboard (that’s why some programming contests have no participants from this university).
Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
Input
There are multiple cases (no more than 40 cases).
The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.
Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can’t be put on the billboard, output “-1” for this announcement.
Sample Input
3 5 5
2
4
3
3
3
Sample Output
1
2
1
3
-1

题意是有一块长h宽w的板子,你可以往上贴广告,位置优先越靠上。
max维护一个剩余最大的空间,若最大空间Max[1]小于广告的宽度,则直接返回-1.
线段树搜索第一个大于等于w值的位置,query和update写一起。
注意h的值,线段树开的空间应该根据n来开。
而且输入规模过大,不要用Scanner,用BufferedReader输入。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
public class Main{
    public static int[] max;
    public static void pushUp(int rt){
        max[rt]=Math.max(max[rt<<1],max[rt<<1|1]);
    }
    public static void build(int l,int r,int rt,int val){
        max[rt]=val;
        if(l==r)return;
        int mid=(l+r)>>1;
        build(l,mid,rt<<1,val);
        build(mid+1,r,rt<<1|1,val);
    }
    public static int query(int w,int l,int r,int rt){
        if(l==r){
            max[rt]-=w;
            return l;
        }
        int mid=(l+r)>>1;
        int ret;
        if(max[rt<<1]>=w) {
            ret=query(w,l,mid,rt<<1);
        }else{
            ret=query(w,mid+1,r,rt<<1|1);
        }
        pushUp(rt);
        return ret;
    }
    public static void main(String[] args) throws IOException {
        //Scanner cin=new Scanner(System.in);
        BufferedReader reader=new BufferedReader(new InputStreamReader(System.in));
        while (true){
            String[] tmp;
            try{
                tmp=reader.readLine().split("\\s+");
            }catch (Exception e){
                return;
            }
            int h,w,n;
            h=Integer.parseInt(tmp[0]);
            w=Integer.parseInt(tmp[1]);
            n=Integer.parseInt(tmp[2]);
            h=Math.min(h,n);
            if(h!=1){
                max=new int[h<<2];
            }else{
                max=new int[10];
            }
            build(1,h,1,w);
            for(int i=1;i<=n;++i){
                int q=Integer.parseInt(reader.readLine());
                if(max[1]<q){
                    System.out.println("-1");
                }else {
                    System.out.println(query(q,1,h,1));
                }
            }
        }
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值