poj 3080 Blue Jeans(最长公共子串)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11758 Accepted: 5077

Description

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT


题目:给出n个长为六十的字符串,求其最长的公共子串,若相同,则按字典序小的输出:
1:遍历第一个字符串的子串,找到符合要求的子串(不太习惯这样做) 
2:遍历过程中开始筛选符合要求的;
3:用到了一个函数strstr():字符串查找函数:如果可以找到,则返回第一个位置的指针,否则返回NULL;
代码:




#include <iostream>
#include<string.h>
#define N 60
using namespace std;
char str[11][61];//原始字符串数组
int len;//公共子串的长度
void gain_substring(int s,int e,char str1[])//截取子串
{
    int i,k;
    memset(str1,'\0',sizeof(str1[0])*61);
    for(i=s,k=0; i<=e; i++)
    {
        str1[k++]=str[0][i];
    }
}
bool check(char s[],int n)//检验是否为公共子串
{
    int i;

    for(i=0; i<n; i++)
    {
        if(!strstr(str[i],s))//此处便用到了strstr查找函数
        {
            return false;
        }
    }
    return true;
}
void substring(char s[],int n)//求最长公共子串
{
    int i,j;
    char ans[61];
    for(i=0; i<N; i++)
    {
        for(j=N-1; j>i; j--)//两层循环遍历其所有的子串
        {
            gain_substring(i,j,s);
            if((check(s,n)&&(j-i+1)>len)||(check(s,n)&&((j-i+1)==len)&&strcmp(ans,s)>0))//判断条件(用来挑出子串中最大的一个(且为字典序小的))
            {
                len=j-i+1;//记录公共子串的长度
                //cout<<ans<<" "<<len<<endl;
                strcpy(ans,s);//记录子串
            }
        }
    }
    memset(s,'\0',sizeof(s[0])*61);
    strcpy(s,ans);
}
int main()
{
    int t,n,i;
    char s[61];
    while(cin>>t)
    {
        while(t--)
        {
            memset(s,'\0',sizeof(s[0])*61);
            memset(str,'\0',sizeof(str[0])*11);
            cin>>n;
            len=0;
            for(i=0; i<n; i++)
            {
                cin>>str[i];
            }
            substring(s,n);
            if(len<3)
                cout<<"no significant commonalities"<<endl;
            else
                cout<<s<<endl;
        }
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值