poj 3461 Oulipo(KMP 字符串匹配算法)

39 篇文章 0 订阅
4 篇文章 0 订阅
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22354 Accepted: 8922

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

题目:
输入两个字符串,输出,第二个串里有多少个和第一个匹配的子串;
题目给的数据量较大(用 KMP算法 ,建议scanf,printf输入输出),用朴素的字符串匹配算法会超时的;
KMP算法:(源自百度百科)

基本思想

假设在模式匹配的进程中,执行T[i]和W[j]的匹配检查。若T[i]=W[j],则继续检查T[i+1]和W[j+1]是否匹配。若T[i]<&gt;W[j],则分成两种情况:若j=1, 则模式串右移一位,检查T[i+1]和W[1]是否匹配;若1<j<=m,则模式串右移j-next(j)位,检查T[i]和W[next(j)]是否匹配。重复此过程直到j=m或i=n结束; 主要是next[]数组的求解(KMP主要是通过next数组实现跳跃多个字符,提高效率的); 关于next数组的求解请看转载的博客 KMP算法总结 代码:
#include <iostream>
#include<string.h>
#define N 1000001
using namespace std;
int next[N];
char str[N],s[N];
void get_next()//获取next数组
{
    unsigned int i, t,length=strlen(s);
    i = 1;
    t = 0;
    next[1] = 0;
    while(i < length + 1)
    {
        while(t > 0 && s[i - 1] != s[t - 1])
        {
            t = next[t];
        }
        ++t;
        ++i;
        if(s[i - 1] == s[t - 1])
        {
            next[i] = next[t];
        }
        else
        {
            next[i] = t;
        }
    }
    //s末尾的结束符控制,用于寻找目标字符串中的所有匹配结果用
    while(t > 0 && s[i - 1] != s[t - 1])
    {
        t = next[t];
    }
    ++t;
    ++i;
    next[i] = t;
}
int KMP()
{
    int i,j,n;
    int s_length=strlen(s);
    int text_length=strlen(str);
    get_next();//Next(s);
    i = 0;
    j = 1;
    n = 0;
    while(s_length + 1 - j <= text_length - i)
    {
        if(str[i] == s[j - 1])
        {
            ++i;
            ++j;
            if(j==s_length + 1)//匹配则计数加一
            {
               n++;
                j = next[j];
            }
        }
        else//匹配失败则跳到next位置,重新匹配
        {
            j = next[j];
            if(j==0)
            {
                ++i;
                ++j;
            }
        }
    }
    return n;
}
int main()
{
    int t,k;
    while(cin>>t)
    {
        while(t--)
        {
            memset(str,'\0',sizeof(str[0])*124);
            memset(s,'\0',sizeof(s[0])*124);
            cin>>(s);
            cin>>(str);
            k=KMP();
            cout<<k<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值