poj3461 Oulipo (kmp)

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15688 Accepted: 6302

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A','B','C', …,'Z'} and two finite strings over that alphabet, a wordW and a textT, count the number of occurrences ofW inT. All the consecutive characters of W must exactly match consecutive characters ofT. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B','C', …,'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the stringW).
  • One line with the text T, a string over {'A', 'B','C', …,'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the wordW in the textT.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0
评测链接:http://poj.org/problem?id=3461
解法:
除了英语有点难度,其它都没有难度,属于是kmp算法的基础入门算法。如果你不会kmp,请点击以下的两个链接(我见过的最好的讲解blog):
matrix67:http://www.matrix67.com/blog/archives/tag/kmp%E7%AE%97%E6%B3%95(个人认为这个更好懂一点,思路清晰、简单。)
v_JULY_v:http://blog.csdn.net/v_july_v/article/details/7041827?reload
至于题解,这里就不说了,会kmp的应该都会写。
代码:
</pre><pre name="code" class="cpp">#include<cstdio>
#include<cstring>
#define maxn1 10000
#define maxn2 1000000
using namespace std;

int p[maxn1+20],n,m;
char b[maxn1+20],a[maxn2+20];

int main()
{
  freopen("1.in","r",stdin);
  
  int i,j,k,t,ans;
  scanf("%d",&t);
  while(t--)
    {
      b[0]=a[0]=' ';
      scanf("%s%s",b+1,a+1);
      m=strlen(b),n=strlen(a);
      
	  for(j=0,i=2;i<m;i++)
        {
          while(j>0 && b[j+1]!=b[i])j=p[j];
          if(b[j+1]==b[i])j++;
          p[i]=j;
		}
      
      for(ans=j=0,i=1;i<n;i++)
        {
          while(j>0 && b[j+1]!=a[i])j=p[j];
          if(b[j+1]==a[i])j++;
          if(j==m-1)j=p[j],ans++;
		}
	  printf("%d\n",ans);
	}
  return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值