Homer Simpson+uva+01背包

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

Description

Download as PDF

Return of the Aztecs

Problem C:Homer Simpson

Time Limit: 3 seconds
Memory Limit: 32 MB

Homer Simpson, a very smart guy, likes eating Krusty-burgers. It takes Homer m minutes to eat a Krusty- burger. However, there’s a new type of burger in Apu’s Kwik-e-Mart. Homer likes those too. It takes him n minutes to eat one of these burgers. Given t minutes, you have to find out the maximum number of burgers Homer can eat without wasting any time. If he must waste time, he can have beer.

Input

Input consists of several test cases. Each test case consists of three integers m, n, t (0 < m,n,t < 10000). Input is terminated by EOF.

Output

For each test case, print in a single line the maximum number of burgers Homer can eat without having beer. If homer must have beer, then also print the time he gets for drinking, separated by a single space. It is preferable that Homer drinks as little beer as possible.

Sample Input

3 5 54
3 5 55

Sample Output

18
17
 
  
解决方案:先是01背包时间,让时间尽可能不良费,在是01背包汉堡的个数,在时间尽可能不浪费的情况下尽可能吃更多的汉堡。
code:
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=10005;
int dptime[maxn];
int dpcnt[maxn];
int g[3][maxn];
int main()
{
    int a[2],t;
    while(~scanf("%d%d%d",&a[0],&a[1],&t))
    {
        memset(dptime,0,sizeof(dptime));
        memset(dpcnt,0,sizeof(dpcnt));
        memset(g,0,sizeof(g));
        for(int i=0; i<2; i++)
        {
            for(int j=a[i]; j<=t; j++)
            {
                if(dptime[j]<=dptime[j-a[i]]+a[i])
                {
                    if(dptime[j]<dptime[j-a[i]]+a[i])
                    {
                        dptime[j]=dptime[j-a[i]]+a[i];
                        dpcnt[j]=dpcnt[j-a[i]]+1;
                    }
                    else
                    {
                        dpcnt[j]=max(dpcnt[j],dpcnt[j-a[i]]+1);
                    }

                }
            }
        }
        if(dptime[t]==t)
            printf("%d\n",dpcnt[t]);
        else
            printf("%d %d\n",dpcnt[t],t-dptime[t]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值