关闭

Eclipse安装Scala插件

标签: eclipsescalascala-idespark插件
4753人阅读 评论(0) 收藏 举报
分类:

scala插件的安装及使用


获取

首先进入scala-ide 主页,了解最新情形。注意scala-ide并不是一个独立的ide,它只是eclipse的一个插件。

进入下载界面,获取最新下载链接–“http://download.scala-ide.org/sdk/lithium/e44/scala211/stable/site ”,特别注意该下载链接所适用的JDK和eclipse等版本,比如上述下载链接的系统需求为:JDK–6,7,8均可;Eclipse 4.4 (Luna) and Eclipse 4.5 (Mars)均可。


安装

在eclipse中,选择“Help->Install New SoftWare”,填上获得的下载链接,选择前两项,安装后重启即可。

上述链接是scala-ide的4.2.0版,包含的内容有:

  • Scala 2.11.7 and Scala 2.10.5
  • Sbt 0.13.8
  • Scalariform 0.1.6
  • Scala Refactoring 0.7.0

使用

装好之后,新建Scala工程,会自动导入Scala Library(2.11.7)和 JRE System Library。不过,为在本地运行,还需导入Spark的jar包–spark-1.4.1-bin-hadoop2.6/lib/spark-assembly-1.4.1-hadoop2.6.0.jar,该包在Spark目录下的lib文件夹里。


问题汇总


问题1:安装插件后,打开eclpse,显示jdt未激活

此问题是由于下载的插件版本与eclipse不匹配造成的,卸载重装。


问题2:

More than one scala library found in the build path (/home/asin/.eclipse/org.eclipse.platform_4.4.2_1786068630_linux_gtk_x86_64/plugins/org.scala-lang.scala-library_2.11.7.v20150622-112736-1fbce4612c.jar, /home/asin/SoftWare/spark-1.4.1-bin-hadoop2.6/lib/spark-assembly-1.4.1-hadoop2.6.0.jar).At least one has an incompatible version. Please update the project build path so it contains only one compatible scala library.   test        Unknown Scala Classpath Problem

该问题是指由于导入的scala包和spark包不兼容,导致部分包重复。此时,往往是因为scala的版本过高的问题,右击工程,选择Scala->Set the Scala Installation,选择2.10.5即可。

另外,给出我的环境配置,供大家参考。

eclipse JDK scala spark hadoop
4.4.2 luna 1.8.0_45 2.10.5 1.4.1 2.6.0
3
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:245240次
    • 积分:4018
    • 等级:
    • 排名:第8048名
    • 原创:148篇
    • 转载:2篇
    • 译文:1篇
    • 评论:29条
    联系方式
    博客专栏
    文章分类
    最新评论