九度OJ-1043:Day of Week


题目描述:

We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入:

There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出:

Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入:
9 October 2001
14 October 2001
样例输出:
Tuesday
Sunday
提示:

Month and Week name in Input/Output:
January, February, March, April, May, June, July, August, September, October, November, December
Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, Saturday

来源:
2008年上海交通大学计算机研究生机试真题
答疑:
解题遇到问题?分享解题心得?讨论本题请访问: http://t.jobdu.com/thread-7767-1-1.html
#include <iostream>
#include <string.h> 
#define isLeapYear(year) (year%4==0&&year%100!=0)||year%400==0
using namespace std;

int buf[10000][13][32];
int dayOfMonth[13][2]={
0,0,
31,31,//1
28,29,
31,31,
30,30,
31,31,
30,30,
31,31,//7
31,31,
30,30,
31,31,
30,30,
31,31
};

struct Date{
	int year;
	int month;
	int day;
	
	void nextDay(){
		day++;
		if (day>dayOfMonth[month][isLeapYear(year)]){
			day=1;
			month++;
			if (month>12){
				month=1;
				year++;
			}
		}
	}
};

int main(){
	//initiate
	Date dateTest;
	dateTest.year=1;
	dateTest.month=1;
	dateTest.day=1;
	int count=0;
	int year,month_number,day;
	char month_name[10];
	
	int dayOfWeek;
	//preprocess 
	while (dateTest.year<10000){
		buf[dateTest.year][dateTest.month][dateTest.day]=count;
		dateTest.nextDay();
		count++;	
	}
	//calculate
	while (cin>>day>>month_name>>year){
		//cal month_number
		if (strcmp(month_name,"January")==0)
			month_number=1;
		else if (strcmp(month_name,"February")==0)
			month_number=2;
		else if (strcmp(month_name,"March")==0)
			month_number=3;
		else if (strcmp(month_name,"April")==0)
			month_number=4;
		else if (strcmp(month_name,"May")==0)
			month_number=5;
		else if (strcmp(month_name,"June")==0)
			month_number=6;
		else if (strcmp(month_name,"July")==0)
			month_number=7;
		else if (strcmp(month_name,"August")==0)
			month_number=8;
		else if (strcmp(month_name,"September")==0)
			month_number=9;
		else if (strcmp(month_name,"October")==0)
			month_number=10;
		else if (strcmp(month_name,"November")==0)
			month_number=11;
		else if(strcmp(month_name,"December")==0)
			month_number=12;
		//cal dayOfWeek
		dayOfWeek=((buf[year][month_number][day]-buf[2017][1][1])%7+7)%7;
		//output
		switch (dayOfWeek){
			case 1:
				cout<<"Monday";
				break;
			case 2:
				cout<<"Tuesday";
				break;
			case 3:
				cout<<"Wednesday";
				break;
			case 4:
				cout<<"Thursday";
				break;
			case 5:
				cout<<"Friday";
				break;
			case 6:
				cout<<"Saturday";
				break;
			case 0:
				cout<<"Sunday";
				break;
		}
		cout<<endl;
	}
	return true;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值