BestCoder #47 1001&&1002

【比赛链接】clikc here~~

ps:真是wuyu~~做了两小时,A出两道题,最后因为没加longlong全部被别人hack掉!,最后居然不知道hack别人不成功也会掉分,还一个劲的hack 别人的代码,昨天真是个悲催的比赛,~~~~(>_<)~~~~,下面弱弱献上代码~~

1002比1001还简单~~

1002  Senior's Gun

/*
BestCoder Round #47
1002   Senior's Gun

*/
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

#define rep(i,j,k) for(int i=(int)j;i<=(int)k;i++)
#define per(i,j,k) for(int i=(int)j;i>=(int)k;i--)
typedef long long LL;
typedef unsigned long long LLU;
typedef double db;

const int N =2*1e5+10;
int n,m,t,p,res,cnt;
LL ans,tmp;
int num[N];
int aa[N],bb[N];
char str[N];
bool vis[N];

int main()
{
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d",&n,&m);
        for (int i=1; i<=n; i++) scanf("%d",&aa[i]);
        for (int i=1; i<=m; i++) scanf("%d",&bb[i]);
        sort(aa+1,aa+n+1);
        sort(bb+1,bb+m+1);
        ans=0;
        int j=n;
        for (int i=1; i<=min(n,m); i++)
            if(aa[j]>bb[i])
            {
                ans+=aa[j]-bb[i];
                j--;
            }
            else break;
        printf("%I64d\n",ans);
    }
    return 0;
}

Sample Input
1
2 2
2 3
2 2
Sample Output
1

1001 Senior's Array

/*
BestCoder Round #47
1001   Senior's Array

*/
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

#define rep(i,j,k) for(int i=(int)j;i<=(int)k;i++)
#define per(i,j,k) for(int i=(int)j;i>=(int)k;i--)
typedef long long LL;
typedef unsigned long long LLU;
typedef double db;

const int N =2*1e4+10;
int n,m,t,p;
int aa[N],bb[N];
char str[N];
bool vis[N];

int main()
{
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d",&n,&p);
        rep(i,1,n) scanf("%d",&aa[i]);
        LL ans=-1e9;
        rep(i,1,n)
        {
            int tmp=aa[i];
            aa[i]=p;
            LL now=0;
            rep(j,1,n)
            {
                now+=(1ll)*aa[j];
                if(now>ans) ans=now;
                if(now<0) now=0;
            }
            aa[i]=tmp;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


Sample Input
2
3 5
1 -1 2
3 -2
1 -1 2
Sample Output
8
2

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值