UVa644_Immediate Decodability(小白书字符串专题)

Description


  Immediate Decodability 

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable



解题报告

我只能说是艰难的历程,集训一下午才解出一题,WA一次,刚才还不知道出问题在哪呢,结果让小伙伴除了一组数据测试,才知道问题在哪。。。

我的思路是先排序,按长度来排序,然后再比较是否是前缀。。。

#include<stdio.h>
#include<string.h>
int main()
{
    int i,l[10],k,j,t,p,q=0,m=0,n=0;
    char str[8][11],ch[11];
    while(gets(str[0])!=NULL)
    {
        n++;
        i=1;
        l[0]=strlen(str[0]);
        while(gets(str[i])!=NULL)
        {
            if(str[i][0]=='9')
            break;
            l[i]=strlen(str[i]);
            i++;
        }
        for(j=0;j<i;j++)
            for(k=j+1;k<i;k++)
                if(l[j]>l[k])
                {
                    strcpy(ch,str[j]);
                    strcpy(str[j],str[k]);
                    strcpy(str[k],ch);
                    t=l[j];
                    l[j]=l[k];
                    l[k]=t;
                }
        for(j=0;j<i-1;j++)
        {
            q=0;
            for(k=j+1;k<i;k++)
            {
                q=0;
                for(p=0;p<l[j];p++)
                if(str[j][p]==str[k][p])
                    q++;
                if(q==l[j])
                    m++;
            }
        }
        if(m!=0)
        {
            printf("Set %d is not immediately decodable\n",n);
            m=0;
        }
        else printf("Set %d is immediately decodable\n",n);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值