HDU 1305 Immediate Decodability 简单字典树 题意

Immediate Decodability

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3644    Accepted Submission(s): 1899


Problem Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
 

Input
Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
 

Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
 

Sample Input
  
  
01 10 0010 0000 9 01 10 010 0000 9
 

Sample Output
  
  
Set 1 is immediately decodable Set 2 is not immediately decodable
 

Source
 

Recommend
Eddy
 

读题俩小时,做题十分钟很难受,我好好说下题意

给你一系列数,如果其中有一个字符串a是字符串b的前缀,那么字符串b就是不可立即解码,输出is not immediately decodable

如果没有这样的 字符串,那么就是可解码的,输出is immediately decodable


字典树(数组实现ac代码)

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>

using namespace std;

int tree[1000010][2]={0};
int pos=1;
int num[1000010]={0};
int cas=0;

struct node{
    char s[15];
    int length;
}nn[25];

bool cmp(node A,node B){
    return A.length < B.length;
}

void Insert(char *s){
    int c=0;

    for(int i=0;s[i];i++){
        int n=s[i] - '0';
        if(tree[c][n]==0)
            tree[c][n]=pos++;
        c=tree[c][n];
        num[c]++;
    }

}

int Find(char s[]){
    int c=0;
    for(int i=0;s[i];i++){
        int tmp=s[i]-'0';
        if(tree[c][tmp] == 0)
            return 0;
        c=tree[c][tmp];
    }
    return num[c];
}

int main(){

    int cnt=1;
    while( ~scanf("%s",nn[cnt].s) ){
        Insert(nn[cnt].s);
        if(nn[cnt].s[0]=='9'){
            int flag=1;
            sort(nn+1,nn+cnt,cmp);
            for(int i=1;i<cnt;i++){
                if(Find(nn[i].s) > 1){
                    flag=0;
                    break ;
                }

            }
            printf("Set %d",++cas);
            if(flag)
                printf(" is immediately decodable\n");
            else
                printf(" is not immediately decodable\n");
            cnt=1;
            memset(tree,0,sizeof(tree));
            memset(num,0,sizeof(num));
            continue ;
        }
        nn[cnt].length=strlen(nn[cnt].s);
        cnt++;
    }

    return 0;
}

链表实现(浪费内存)

my ugly code

#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>

using namespace std;
int cas=1;
struct node{
    node *nxt[2];
    int num;

    node(){
        nxt[0]=nxt[1]=NULL;
        num=0;
    }
};

void Insert(char s[],node *root){
    node *p=root;

    for(int i=0;s[i];i++){
        if(p->nxt[s[i]-'0'] == NULL){
            p->nxt[s[i] - '0'] = new node;
        }
        p=p->nxt[s[i] - '0'];
        p->num++;
    }
}

int Find(char s[],node *root){
    node *p=root;

    for(int i=0;s[i];i++){
        if(p->nxt[s[i]-'0'] == NULL)
            return 0;
        p=p->nxt[s[i]-'0'];
    }
    return p->num;
}


int main(){

    char s[25][25];

    int cnt=1;
    node *root=new node;
    while(~scanf("%s",s[cnt])){
        if(s[cnt][0] == '9'){
            int flag=1;
            for(int i=1;i<cnt;i++){
                if(Find(s[i],root) > 1){
                    flag=0;
                    break ;
                }
            }
            printf("Set %d",cas++);
            if(flag)
                printf(" is immediately decodable\n");
            else
                printf(" is not immediately decodable\n");
            cnt=1;
            root=new node;
            continue ;
        }
        Insert(s[cnt],root);
        cnt++;
    }

    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值