【POJ】1984 Navigation Nightmare 带权并查集

Navigation Nightmare
Time Limit: 2000MS
Memory Limit: 30000K
Total Submissions: 4054
Accepted: 1606
Case Time Limit: 1000MS

Description

Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n):
           F1 --- (13) ---- F6 --- (9) ----- F3

            |                                 |

           (3)                                |

            |                                (7)

           F4 --- (20) -------- F2            |

            |                                 |

           (2)                               F5

            | 

           F7 

Being an ASCII diagram, it is not precisely to scale, of course.

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path
(sequence of roads) links every pair of farms.

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road:

There is a road of length 10 running north from Farm #23 to Farm #17
There is a road of length 7 running east from Farm #1 to Farm #17
...

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob:

What is the Manhattan distance between farms #1 and #23?

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms.
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points).

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1".

Input

* Line 1: Two space-separated integers: N and M



* Lines 2..M+1: Each line contains four space-separated entities, F1,

        F2, L, and D that describe a road. F1 and F2 are numbers of

        two farms connected by a road, L is its length, and D is a

        character that is either 'N', 'E', 'S', or 'W' giving the

        direction of the road from F1 to F2.



* Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's

        queries



* Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob

        and contains three space-separated integers: F1, F2, and I. F1

        and F2 are numbers of the two farms in the query and I is the

        index (1 <= I <= M) in the data after which Bob asks the

        query. Data index 1 is on line 2 of the input data, and so on.

Output

* Lines 1..K: One integer per line, the response to each of Bob's

        queries.  Each line should contain either a distance

        measurement or -1, if it is impossible to determine the

        appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6

Sample Output

13
-1
10

Hint

At time 1, FJ knows the distance between 1 and 6 is 13.
At time 3, the distance between 1 and 4 is still unknown.
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10.

Source

USACO 2004 February

传送门:【POJ】1984 Navigation Nightmare

题目大意:
农夫约翰有 N 个农场,标号 1 到 N.M 条的不同的垂直或水平的道路连接着农场,道路的长度不超过 1000。这些农场的分布就像下面的地图一样,图中农场用 F1..F7 表示:
           F1 --- (13) ---- F6 --- (9) ----- F3

            |                                 |

           (3)                                |

            |                                (7)

           F4 --- (20) -------- F2            |

            |                                 |

           (2)                               F5

            | 

           F7 
每个农场最多能在东西南北四个方向连接 4 个不同的农场。此外,农场只处在道路的两端。道路不会交叉且每对农场间有且仅有一条路径。邻居鲍勃要约翰来导航,但约翰丢了农场的地图,他只得从电脑的备份中修复了。每一条道路的信息如下:
从农场 23 往南经距离 10 到达农场 17
从农场 1 往东经距离 7 到达农场 17
……
当约翰重新获得这些数据时,他有时被鲍勃的问题打断:“农场 1 到农场 23 的曼哈顿距离是多少?”所谓在(x1,y1)和(x2,y2)之间的“曼哈顿距离”,就是|x1-x2|+|y1-y2|。如果已经有足够的信息,约翰就会回答这样的问题 (在上例中答案是 17), 否则他会诚恳地抱歉并回答-1。

题目分析:经典的带权并查集~
设所有的根结点的X,Y坐标为0,然后每次更新时就更新每个点到根结点的相对坐标即可。合并的时候根据两个要合并的点到各自根结点的相对坐标以及两点之间的相对位移,可以得到一个根结点相对另一个根结点的坐标。
设root[ x ]为x的根结点,X[ x ]为x到根结点的相对X坐标,Y[ x ]为y到根结点的相对Y坐标,dx为x到y的相对X位移,dy为x到y的相对Y位移。可得:
X[ root[ x ] ] = dx - X[ x ] + X[ y ] ;
Y[ root[ x ] ] = dy - Y[ x ] + Y[ y ] ;
接下来就很方便了,对于每个查询,邻接表保存即可。

代码如下:


#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;

#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REPV( i , a , b ) for ( int i = a ; i >= b ; -- i )
#define clear( a , x ) memset ( a , x , sizeof a )

const int MAXN = 50000 ;
const int MAXE = 50000 ;

struct Edge {
	int x , y , n ;
	int idx ;
	void input ( int __idx ) {
		scanf ( "%d%d" , &x , &y ) ;
		idx = __idx ;
	}
} ;

struct Line {
	int x , y , d ;
	char ch[5] ;
	void input () {
		scanf ( "%d%d%d%s" , &x , &y , &d , ch ) ;
	}
} ;

Edge edge[MAXE] ;
Line line[MAXN] ;
int adj[MAXN] , cntE ;
int p[MAXN] ;
int X[MAXN] , Y[MAXN] ;
int ask[MAXN] ;
int n , m , t ;

int find ( int x ) {
	int tmp ;
	if ( p[x] == x )
		return x ;
	tmp = find ( p[x] ) ;
	X[x] += X[p[x]] ;
	Y[x] += Y[p[x]] ;
	return p[x] = tmp ;
}

void work () {
	int x , y , day , d ;
	while ( ~scanf ( "%d%d" , &n , &m ) ) {
		clear ( adj , -1 ) ;
		cntE = 0 ;
		REPF ( i , 1 , n )
			p[i] = i , X[i] = Y[i] = 0 ;
		REPF ( i , 1 , m )
			line[i].input () ;
		scanf ( "%d" , &t ) ;
		REP ( i , t ) {
			edge[cntE].input ( i ) ;
			scanf ( "%d" , &day ) ;
			edge[cntE].n = adj[day] ;
			adj[day] = cntE ++ ;
		}
		REPF ( i , 1 , m ) {
			x = find ( line[i].x ) ;
			y = find ( line[i].y ) ;
			d = line[i].d ;
			if ( x != y ) {
				p[x] = y ;
				if ( line[i].ch[0] == 'E' )
					X[x] = -X[line[i].x] + X[line[i].y] - d , Y[x] = -Y[line[i].x] + Y[line[i].y] ;
				else if ( line[i].ch[0] == 'W' )
					X[x] = -X[line[i].x] + X[line[i].y] + d , Y[x] = -Y[line[i].x] + Y[line[i].y] ;
				else if ( line[i].ch[0] == 'N' )
					Y[x] = -Y[line[i].x] + Y[line[i].y] - d , X[x] = -X[line[i].x] + X[line[i].y] ;
				else
					Y[x] = -Y[line[i].x] + Y[line[i].y] + d , X[x] = -X[line[i].x] + X[line[i].y] ;
			}
			for ( int j = adj[i] ; ~j ; j = edge[j].n ) {
				x = edge[j].x ;
				y = edge[j].y ;
				int flag = ( find ( x ) == find ( y ) ) ;
				ask[edge[j].idx] = ( flag ? abs ( X[x] - X[y] ) + abs ( Y[x] - Y[y] ) : -1 ) ;
			}
		}
		REP ( i , t )
			printf ( "%d\n" , ask[i] ) ;
	}
}

int main () {
	work () ;
	return 0 ;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值