Navigation Nightmare(带权并查集)

Navigation Nightmare

Farmer John’s pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1…N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1…F7 for clarity and lengths between connected farms are shown as (n):

           F1 --- (13) ---- F6 --- (9) ----- F3

            |                                 |

           (3)                                |

            |                                (7)

           F4 --- (20) -------- F2            |

            |                                 |

           (2)                               F5

            | 

           F7 

Being an ASCII diagram, it is not precisely to scale, of course.

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path
(sequence of roads) links every pair of farms.

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road:

There is a road of length 10 running north from Farm #23 to Farm #17
There is a road of length 7 running east from Farm #1 to Farm #17

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob:

What is the Manhattan distance between farms #1 and #23?

FJ answers Bob, when he can (sometimes he doesn’t yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the “Manhattan” distance between the pair of farms.
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points).

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with “-1”.

Input
  • Line 1: Two space-separated integers: N and M

  • Lines 2…M+1: Each line contains four space-separated entities, F1, F2, L, and D that describe a road. F1 and F2 are numbers of two farms connected by a road, L is its length, and D is a character that is either ‘N’, ‘E’, ‘S’, or ‘W’ giving the direction of the road from F1 to F2.

  • Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB’s queries

  • Lines M+3…M+K+2: Each line corresponds to a query from Farmer Bob and contains three space-separated integers: F1, F2, and I. F1 and F2 are numbers of the two farms in the query and I is the index (1 <= I <= M) in the data after which Bob asks the query. Data index 1 is on line 2 of the input data, and so on.

Output

Lines 1…K: One integer per line, the response to each of Bob’s queries. Each line should contain either a distance measurement or -1, if it is impossible to determine the appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6

Sample Output

13
-1
10

Hint

At time 1, FJ knows the distance between 1 and 6 is 13.
At time 3, the distance between 1 and 4 is still unknown.
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10.

题意

有n个网格状的农田,每个农田之间有距离,会依次给出关系,在给出关系后询问两个农田之间的曼哈顿距离是多少?

若无法判断则输出-1。

对于每组案例:
首先输入两个数字n和m,表示有n块农田,农田从1开始编号。
接下来m行,每行给出a,b,l,d,a和b表示农田的编号,l表示之间的距离,d表示b在a的d侧(只有四种,北-N,南-S,西-W,东-E)。
然后输入一个数字k,代表询问次数。
之后输入k行,每行有三个数字a,b,c,表示在c行后询问a,b间的曼哈顿距离是多少?
(1 <= M < 40,000)
(2 <= N <= 40,000)
(1 <= K <= 10,000)

代码
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>

using namespace std;

#define maxn 40000+10
#define maxv 10000+10
struct node//存储输入的数据
{
    int u, v, length;
    char s;
} q[maxn];

struct question//存储询问
{
    int u, v, index, pos;

    friend bool operator<(question a, question b) {
        return a.index < b.index;
    }
} w[maxv];

struct gather//并查集
{
    int x, y, pre;
} g[maxn];
struct result//存储答案
{
    int ans, pos;
} e[maxv];
int n, m;

bool cmp(result a, result b) {
    return a.pos < b.pos;
}

void init() {
    for (int i = 1; i <= n; i++) {
        g[i].pre = i;
        g[i].x = g[i].y = 0;
    }
}

int Find(int x) {
    int temp = g[x].pre;
    if (x == g[x].pre) {
        return x;
    }
    g[x].pre = Find(temp);
    g[x].x += g[temp].x;
    g[x].y += g[temp].y;
    return g[x].pre;
}

void join(int u, int v, int length, char s) {
    int fx = Find(u), fy = Find(v);
    if (fx != fy) {
        g[fx].pre = fy;
        if (s == 'N') {
            g[fx].y = g[v].y + length - g[u].y, g[fx].x = g[v].x - g[u].x;
        } else if (s == 'S') {
            g[fx].y = g[v].y - length - g[u].y, g[fx].x = g[v].x - g[u].x;
        } else if (s == 'E') {
            g[fx].x = g[v].x + length - g[u].x, g[fx].y = g[v].y - g[u].y;
        } else {
            g[fx].x = g[v].x - length - g[u].x, g[fx].y = g[v].y - g[u].y;
        }
    }
}

int main() {
    scanf("%d%d", &n, &m);
    init();
    int i, k;
    for (i = 0; i < m; i++) {
        scanf("%d%d%d %c", &q[i].u, &q[i].v, &q[i].length, &q[i].s);
    }
    scanf("%d", &k);
    for (i = 0; i < k; i++) {
        scanf("%d%d%d", &w[i].u, &w[i].v, &w[i].index), w[i].pos = i;
    }
    sort(w, w + k);
    int ans, j = 0;
    for (i = 0; i < k; i++) {
        for (; j < w[i].index; j++) {
            join(q[j].u, q[j].v, q[j].length, q[j].s);
        }
        int u = w[i].u, v = w[i].v;
        int fx = Find(u), fy = Find(v);
        if (fx != fy) {
            ans = -1;
        } else {
            ans = abs(g[u].x - g[v].x) + abs(g[u].y - g[v].y);
        }
        e[i].ans = ans, e[i].pos = w[i].pos;
    }
    sort(e, e + k, cmp);
    for (int i = 0; i < k; ++i) {
        printf("%d\n", e[i].ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值