POJ 3009 Curling 2.0 (dfs)

31 篇文章 0 订阅

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12700 Accepted: 5343

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

Source




题意:一种游戏,规则是:从起点S出发,在没有障碍的直线上会一直不停的行进直到遇到障碍或到达终点G停止。在遇到障碍时,要停在障碍前,然后障碍就会消除,然后重新选择四个方向行进。输入图中2代表起点,3代表终点,0代表无障碍区域,1代表障碍区域。求要从起点到达终点最少需要停多少次。


解析:dfs。

PS:C++交的结果是RE,G++是AC




AC代码:

#include<iostream>
#include<stdio.h>
#include<stdio.h>
#include<string.h>
using namespace std;
int vis[25][25];
int n,m;
int sx,sy,ex,ey;
int flag,minstep;        //flag标记是否找到路径,minstep记录总的步数
int d[4][2] = {1,0,0,1,-1,0,0,-1};   //移动的方向

void dfs(int x, int y, int step){    //当前位置,步数
    int dx, dy;
    if(step >= 10) return ;
    for(int i=0; i<4; i++){
        if(!vis[ x+d[i][0] ][ y+d[i][1] ]){
            dx = x;
            dy = y;
            while(!vis[ dx+d[i][0] ][ dy+d[i][1] ]){    //判断下一个节点是否是障碍
                dx = dx + d[i][0];                      //符合条件才加
                dy = dy + d[i][1];
                if(dx == ex && dy == ey){
                    if(minstep > step + 1) minstep = step + 1;
                    flag = 1;
                    return ;
                }
                if(dx < 0 || dx >= n || dy < 0 || dy >= m) break;  //判断越界
            }
            if(dx >= 0 && dx < n && dy >= 0 && dy < m && step + 1 < 10){    //与障碍撞上后
                vis[ dx+d[i][0] ][ dy+d[i][1] ] = 0;      //去除障碍
                dfs(dx, dy, step+1);
                vis[ dx+d[i][0] ][ dy+d[i][1] ] = 1;      //回溯
            }  
        }
    }
}

int main()
{
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk


    int i,j;
    while(scanf("%d%d", &m, &n)!=EOF && !(!m && !n)){
        memset(vis, 0, sizeof(vis));              //不加这句,竟然WA
        for(i=0; i<n; i++)
            for(j=0; j<m; j++){
                scanf("%d", &vis[i][j]);
                if(vis[i][j]==2){
                    sx = i;
                    sy = j;
                    vis[i][j] = 0;
                }
                else if(vis[i][j]==3){
                    ex = i;
                    ey = j;
                    vis[i][j] = 0;
                }
            }
        minstep = 99999999;
        flag = 0;
        dfs(sx, sy, 0);
        if(!flag) minstep = -1;
        printf("%d\n", minstep);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值