LA 5009 (HDU 3714) Error Curves (三分)

10 篇文章 1 订阅
9 篇文章 0 订阅

Error Curves
Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu
Appoint description:

Description

Download as PDF Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties.

In order to test the algorithm's efficiency, she collects many datasets. What's more, each data is divided into two parts: training data and test data. She gets the parameters of the model on training data and test the model on test data.

To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the formf(x) = ax2 + bx + c. The quadratic will degrade to linear function ifa = 0.

Quadric Function

It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimal which related to multiple quadric functions.

The new function F(x) is defined as follow:

F(x) = max(Si(x)), i = 1...n. The domain ofx is [0, 1000].Si(x) is a quadric function.

Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n(n ≤ 10000). Followingn lines, each line contains three integersa (0 ≤ a ≤ 100),b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input
2
1
2 0 0
2
2 0 0
2 -4 2
Sample Output
0.0000
0.5000



大致题意:给了好多抛物线f(i)的a[i], b[i],  c[i], 定义F (i)= max(f(i)) , 求F(x)在区间【0,1000】上的最小值。


解题思路:由于题中给出的a>=0, 所以a有可能为零,此时曲线为直线,否则曲线为开口向上的抛物线,故为下凸函数,所以F(x)也为下凸函数。故可用三分法求F(x)的极值。先算出F(x)的具体值,然后就可直接三分了。详见代码





AC代码:

#include <cstdio>
#include <algorithm>
using namespace std;

const int maxn = 10000 + 10;
int n, a[maxn], b[maxn], c[maxn];

double f(double x){                //求F(x)
	double ans = a[0]*x*x + b[0]*x + c[0];
	for(int i=1; i<n; i++){
		ans = max(ans, a[i]*x*x+b[i]*x+c[i]);
	}
	return ans;
}


int main(){
//	freopen("in.txt","r",stdin);
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d", &n);
		for(int i=0; i<n; i++)
			scanf("%d%d%d", &a[i], &b[i], &c[i]);
		double l = 0, r = 1000;           //三分求极值
		for(int i=0; i<100; i++){
			double mid = l + (r-l)/3;
			double midmid = r - (r-l)/3;
			if(f(mid) < f(midmid))  r = midmid;
			else  l = mid;
		}
		printf("%.4lf\n",f(l));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值