hdu 1312

http://acm.hdu.edu.cn/showproblem.php?pid=1312

Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
在做感觉就是好,一次过。。。。
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
const int N=1005;
char a[N][N];
int dis[N][N];
int m,n,cnt;
int xx[]={1,0,-1,0};
int yy[]={0,1,0,-1};
void bfs(int x,int y)
{
    if(a[x][y]=='#')
        return;
    for(int i=0;i<4;i++)
    {
         int dx=x+xx[i];
         int dy=y+yy[i];
         if(dis[dx][dy]==0&&dx>=0&&dx<n&&dy>=0&&dy<m&&a[dx][dy]=='.')
         {
             dis[dx][dy]=1;
             cnt++;
             bfs(dx,dy);
         }
    }
}
int main()
{
    int x,y;
    while(~scanf("%d%d",&m,&n))
    {
        if(n==0&&m==0)
            break;
        getchar();
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            {
                cin >> a[i][j];
                if(a[i][j]=='@')
                    x=i,y=j;
            }
        memset(dis,0,sizeof(dis));
        cnt=0;
        bfs(x,y);
        printf("%d\n",cnt+1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值