HDU 1312

9 篇文章 0 订阅

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28249    Accepted Submission(s): 17084


 

Problem Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

 

 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 

 

 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

 

 

Sample Input

 

6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0

 

 

Sample Output

 

45 59 6 13

 

 

Source

Asia 2004, Ehime (Japan), Japan Domestic

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1312

题意:根据地图,问可以到达多少地方.'@'为起点, ' . '为路,可以到达, ' # '为墙,不能通过.

思路:以起点为中心开始进行dfs,将走过的点全部标记起来(变为墙),最后输出走的步数。

注意:输入的时候要注意回车(因为我是用%c一个一个读取的,如果不处理最末的回车就会出现错误)。

 

代码:

#include <iostream>
#include <string>
#include <stdlib.h>
#include <stdio.h>

using namespace std;

int ans;
int n, m;
int book[20][20];
int b[4][2] = {{0, 1},{0, -1}, {1,0},  {-1, 0}};

void dfs(int x, int y)
{
    ans++;
    for(int i = 0; i < 4; i++)
    {
        int tx = x + b[i][0];
        int ty = y + b[i][1];
        if(book[tx][ty] == 0 && tx >= 0 && tx < n && ty >= 0 && ty < m)
        {
            book[tx][ty] = 1;
            dfs(tx, ty);
        }
    }
}

int main()
{
    char ch;
    int x, y;
    while(scanf("%d %d", &m, &n), n || m)
    {
        getchar();
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                scanf("%c", &ch);
                if(ch == '@')
                {
                    book[i][j] = 1;
                    x = i;
                    y = j;
                }
                else if(ch == '#')
                    book[i][j] = 1;
                else
                    book[i][j] = 0;
            }
            getchar();
        }
        ans = 0;
        dfs(x, y);
        printf("%d\n", ans);
    }
    return 0;
}

BFS代码

#include <iostream>
#include <string>
#include <stdlib.h>
#include <stdio.h>

using namespace std;


int mp[500][2];
bool book[25][25];
int n, m;
int ans;
int a[4][2] = {{0, 1},{0, -1}, {1,0}, {-1, 0}};

void bfs()
{
    int h = 0, l = 1;
    while(h < l)
    {
        for(int i = 0; i < 4; i++)
        {
            int tx = mp[h][0] + a[i][0];
            int ty = mp[h][1] + a[i][1];
            if(book[tx][ty] == 0 && tx >= 0 && tx < n && ty >= 0 && ty < m)
            {
                mp[l][0] = tx;
                mp[l][1] = ty;
                l++;
                ans++;
                book[tx][ty] = 1;
            }
        }
        h++;
    }
}

int main()
{
    char ch;
    while(scanf("%d %d", &m, &n), m || n)
    {
        getchar();
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                scanf("%c", &ch);
                if(ch =='@')
                {
                    book[i][j] = 1;
                    mp[0][0] = i;
                    mp[0][1] = j;
                }
                else
                    if(ch == '#')
                book[i][j] = 1;
                else
                    book[i][j] = 0;

            }
            getchar();
        }
        ans = 1;
        bfs();
        printf("%d\n", ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值