HDU 5154 Harry and Magical Computer

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5154

Harry and Magical Computer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1096    Accepted Submission(s): 450


Problem Description
In reward of being yearly outstanding magic student, Harry gets a magical computer. When the computer begins to deal with a process, it will work until the ending of the processes. One day the computer got n processes to deal with. We number the processes from 1 to n. However there are some dependencies between some processes. When there exists a dependencies (a, b), it means process b must be finished before process a. By knowing all the m dependencies, Harry wants to know if the computer can finish all the n processes.
 

Input
There are several test cases, you should process to the end of file.
For each test case, there are two numbers n m on the first line, indicates the number processes and the number of dependencies. 1n100,1m10000
The next following m lines, each line contains two numbers a b, indicates a dependencies (a, b). 1a,bn
 

Output
Output one line for each test case.
If the computer can finish all the process print "YES" (Without quotes).
Else print "NO" (Without quotes).
 

Sample Input
  
  
3 2 3 1 2 1 3 3 3 2 2 1 1 3
 

Sample Output
  
  
YES NO
拓扑排序模板题。。。

#include<iostream>
#include<queue>
#include<vector>
using namespace std;
const int maxn=105;
vector<int>G[maxn];//定义邻接表
int n,m,in[maxn],Count;
void TopSort()
{
    queue<int>q;
    for(int i=1;i<=n;i++)
        if(in[i]==0) q.push(i);//初始状态入度为0的点即可删除,而现在不直接删除,先将其入度,由于队列是先进先出
        //等出队时再将其删除也不迟
    while(q.size())
    {
        int now=q.front();q.pop();
        Count++;//now将要被删除,故Count计数值加1
        for(int i=0;i<G[now].size();i++)//枚举与now相邻的所有点,因为now的删除将会导致所有以它为起点的边的终点的入度都减一
        {
            int next=G[now][i];
            in[next]--;
            if(in[next]==0) q.push(next);//入度为0即会入队
        }
    }
}
int main()
{
    while(cin>>n>>m)//n个顶点m条边
    {
        for(int i=0;i<=n;i++) G[i].clear();//初始化邻接表
        fill(in,in+maxn,0);//初始化每个点的入度
        Count=0;//记录删掉的点的个数
        while(m--)
        {
            int x,y;
            cin>>x>>y;
            G[x].push_back(y);//存有向边
            in[y]++;//有条x->y的边则y的入度加1
        }
        TopSort();//拓扑排序
        if(Count<n) cout<<"NO"<<endl;
        else cout<<"YES"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值