poj3352 Road Construction (双连通)

Road Construction
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8735 Accepted: 4357

Description

It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v andw, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0
/*
搞了半天搞懂双连通就是变成强连通加了个判断条件不去访问父节点。。。。无语,还好一次过了。加油!!!
Time: 2014-08-17 15:25
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=50010;
struct Edge{
	int to;
	int next;
}edge[MAX<<2];
int low[MAX],dfn[MAX],belong[MAX],head[MAX];
int deg[MAX],stack[MAX];
bool instack[MAX];
int edgeNum,Top,cnt,index,N,M;
void Add(int u,int v){
	edge[edgeNum].to=v;
	edge[edgeNum].next=head[u];
	head[u]=edgeNum++;
}
void Init(){
	edgeNum=cnt=Top=index=0;
	memset(head,-1,sizeof(head));
	memset(dfn,0,sizeof(dfn));
	memset(low,0,sizeof(low));
	memset(deg,0,sizeof(deg));
	memset(belong,0,sizeof(belong));
	memset(stack,0,sizeof(stack));
	while(M--){
		int u,v;
	scanf("%d%d",&u,&v);
	Add(u,v);Add(v,u);
	}
}
void Tarjan(int u,int father){
	dfn[u]=low[u]=++index;
	stack[++Top]=u;instack[u]=true;
	int v;
	for(int i=head[u];~i;i=edge[i].next){
		v=edge[i].to; if(v==father)continue;
		if(dfn[v]==0){
			Tarjan(v,u);
			low[u]=min(low[u],low[v]);
		}else if(instack[v]){
			low[u]=min(low[u],dfn[v]);
		}
	} 
	if(dfn[u]==low[u]){
		cnt++;
		do{
			v=stack[Top--];
			belong[v]=cnt;
			instack[v]=false;
		}while(u!=v);
	}
}
void solve(){
	while(scanf("%d%d",&N,&M)!=EOF){
		Init();
		Tarjan(1,0);//因为所有点都连通只需找一个节点搜索即可 
		int v;
		for(int i=1;i<=N;i++){
			for(int j=head[i];~j;j=edge[j].next){
				v=edge[j].to;
				if(belong[i]!=belong[v]){
					deg[belong[i]]++;deg[belong[v]]++;//因为是无向图 
				}
			}
		}
		int leaf=0;
		for(int i=1;i<=cnt;i++){
			if(deg[i]==2)leaf++;
		}
		int ans=(leaf+1)/2;	
		printf("%d\n",ans);
	}
}
int main(){
	solve();
return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值