poj3264 Balanced Lineup(线段树)

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 36480 Accepted: 17081
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers,  N and  Q
Lines 2.. N+1: Line  i+1 contains a single integer that is the height of cow  i 
Lines  N+2.. N+ Q+1: Two integers  A and  B (1 ≤  A ≤  B ≤  N), representing the range of cows from  A to  B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver
/*
注意不能直接返回根节点的最大值减去最小值。。。。加油!!
Time:2015-1-19 20:54
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

typedef long long LL;

#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
const int MAX=50000+10;
#define INF 0x3f3f3f3f

LL minV,maxV;

struct Tree{
    LL minV,maxV;
}tree[MAX<<2];
void Build(int l,int r,int rt){
    tree[rt].maxV=-INF;
    tree[rt].minV=INF;
    if(l==r)return;
    int mid=(l+r)>>1;
    Build(lson);
    Build(rson);
}
void Insert(int pos,LL val,int l,int r,int rt){
    if(pos==l&&pos==r){
        tree[rt].minV=val;
        tree[rt].maxV=val;
        return;
    }

    int mid=(l+r)>>1;
    if(pos<=mid)Insert(pos,val,lson);
    else if(pos>mid)Insert(pos,val,rson);

    tree[rt].maxV=max(tree[rt].maxV,val);
    tree[rt].minV=min(tree[rt].minV,val);
}

void Query(int L,int R,int l,int r,int rt){
    if(L==l&&R==r){
        minV=min(minV,tree[rt].minV);
        maxV=max(maxV,tree[rt].maxV);
        return;
    }
    int mid=(l+r)>>1;
    if(R<=mid){
        Query(L,R,lson);
    }else if(L>mid){
        Query(L,R,rson);
    }else{
        Query(L,mid,lson);
        Query(mid+1,R,rson);
    }
}
int main(){
    int n,Q;
    LL val;
    scanf("%d%d",&n,&Q);
        memset(tree,0,sizeof(tree));
        Build(1,n,1);
        for(int i=1;i<=n;i++){
            scanf("%lld",&val);
            Insert(i,val,1,n,1);
        }
        int L,R;
        //printf("%d %d\n",tree[1].maxV,tree[1].minV);
        while(Q--){
            minV=INF;maxV=-INF;
            scanf("%d%d",&L,&R);
            Query(L,R,1,n,1);//不能直接返回tree[rt].maxV-tree[rt].minV,
            printf("%lld\n",maxV-minV);
        }
return 0;
}

Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值