hdu4990 Reading comprehension

Reading comprehension

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 692    Accepted Submission(s): 295


Problem Description
Read the program below carefully then answer the question.
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <cstdio>
#include<iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include<vector>

const int MAX=100000*2;
const int INF=1e9;

int main()
{
  int n,m,ans,i;
  while(scanf("%d%d",&n,&m)!=EOF)
  {
    ans=0;
    for(i=1;i<=n;i++)
    {
      if(i&1)ans=(ans*2+1)%m;
      else ans=ans*2%m;
    }
    printf("%d\n",ans);
  }
  return 0;
}
 

Input
Multi test cases,each line will contain two integers n and m. Process to end of file.
[Technical Specification]
1<=n, m <= 1000000000
 

Output
For each case,output an integer,represents the output of above program.
 

Sample Input
  
  
1 10 3 100
 

Sample Output
  
  
1 5
 

Source
BestCoder Round #8 
/*
矩阵真不好玩。。。
注:可得到推导公式f[n]=f[n-1]+2*f[n-2]+1;
|1  2  1|  |f[n-1]| |f[n]  |
|1  0  0|* |f[n-2]|=|f[n-1]|
|0  0  1|  |  1   | |  1   |
加油!!!
Time:2015-04-09 18:10
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
LL mod;
struct Matrix{
    LL mat[3][3];
    LL n;
    void Init(int _n){
        n=_n;
        memset(mat,0,sizeof(mat));
    }
    Matrix operator*(const Matrix &b)const{
        Matrix ret;
        ret.Init(n);
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                for(int k=0;k<n;k++){
                    ret.mat[i][j]+=mat[i][k]*b.mat[k][j];
                    ret.mat[i][j]%=mod;
                }
            }
        }
        return ret;
    }
};
Matrix pow_mat(Matrix a,int k){
    Matrix ret;
    ret.Init(a.n);
    for(int i=0;i<ret.n;i++)ret.mat[i][i]=1;
    while(k>0){
        if(k&1) ret=ret*a;

        a=a*a;
        k>>=1;
    }
    return ret;
}
int main(){
    LL n,m;
    Matrix trans;
    trans.Init(3);
    trans.mat[0][1]=2;
    trans.mat[0][0]=trans.mat[0][2]=trans.mat[1][0]=trans.mat[2][2]=1;
    while(scanf("%lld%lld",&n,&m)!=EOF){
        mod=m;
        Matrix ans,f;
        f.Init(3);ans.Init(3);
        f.mat[0][0]=1;f.mat[1][0]=0;f.mat[2][0]=1;//f[1][0]=
        ans=pow_mat(trans,n-1);
        /*for(int i=0;i<3;i++){
            for(int j=0;j<3;j++){
                printf("%d ",ans.mat[i][j]);
            }puts("");
        }*/
        ans=ans*f;
        printf("%lld\n",ans.mat[0][0]);
    }
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值