hdu acm 4990

Reading comprehension

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1006    Accepted Submission(s): 391

Problem Description
Read the program below carefully then answer the question.
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include <cstdio>
#include<iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include<vector>

const int MAX=100000*2;
const int INF=1e9;

int main()
{
  int n,m,ans,i;
  while(scanf("%d%d",&n,&m)!=EOF)
  {
    ans=0;
    for(i=1;i<=n;i++)
    {
      if(i&1)ans=(ans*2+1)%m;
      else ans=ans*2%m;
    }
    printf("%d\n",ans);
  }
  return 0;
}

Input
Multi test cases,each line will contain two integers n and m. Process to end of file.
[Technical Specification]
1<=n, m <= 1000000000

Output
For each case,output an integer,represents the output of above program.

Sample Input
  
  
1 10 3 100

Sample Output
  
  
1 5

Source

Recommend
heyang   |   We have carefully selected several similar problems for you:  5368 5367 5366 5365 5362

Statistic | Submit | Discuss | Note

数论题目

n                 ans                                                      n                  ans

1                   2^0                                                     2                   2^1

3                   2^0+2^2                                             4                   2^1+2^3

5                   2^0+2^2+2^4                                     6                   2^1+2^3+2^5

7                   2^0+2^2+2^4+2^6                             8                    2^1+2^3+2^5+2^7

...                          .....                                            ...                         ..........

#include<iostream>
using namespace std;
typedef long long LL;
LL M;
long long power(long long a,long long b)
 { long long ans=1;
    int i;
    a=a%M;
     while(b)
     {
         if(b%2==1)
            ans=(ans*a)%M;
         a=(a*a)%M;
         b=b/2;
     }
     return ans;
 }
LL sum(LL p,LL n)
{
    if(n==0) return 1;
    if(n&1)  return (1+power(p,(n-1)/2+1))*sum(p,(n-1)/2)%M;
    else     return ((1+power(p,n/2))*sum(p,n/2)-power(p,n/2))%M;
}
int main()
{
    int i;
    long long n,s;
    while(cin>>n>>M)
    {
            if(n%2==1)
         cout<<sum(4,n/2)%M<<endl;
         else cout<<2*sum(4,n/2-1)%M<<endl;
   }
   return 0;
}

 


 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值