A Multiplication Game

A Multiplication Game

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 102   Accepted Submission(s) : 54
Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

Input
Each line of input contains one integer number n.
 

Output
For each line of input output one line either 

Stan wins. 

or 

Ollie wins.

assuming that both of them play perfectly.
 

Sample Input
  
  
162 17 34012226
 

Sample Output
  
  
Stan wins. Ollie wins. Stan wins.
 

Source
University of Waterloo Local Contest 2001.09.22
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
__int64 a[18];
int main()
{
    __int64 n,i;
    memset(a, 0, sizeof(a));
    a[0] = 1;
    for (int i = 1; i <= 17; i++ )
    {
        if (i % 2 == 1) a[i] = a[i - 1] * 9;
        else a[i] = a[i-1] * 2;
    }
    while (scanf("%I64d", &n) != EOF)
    {
        for (int i = 1; i <= 17; i++)
        {
            if (a[i] >= n)
            {    
                if (i % 2 == 1){ printf("Stan wins.\n"); }
                else printf("Ollie wins.\n");
                break;
            }
        }            
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值