单调队列模板(poj2823)

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7
poj的经验,不能用bits/stdc++.h的头文件。输入要用scanf不然会超时,取消同步也没有用。注意输出的空格。
讲一下题目吧,就是单调队列,用数组(!!切记)模拟队列,然后每次加入一个点,求最小值的话就是使得队列为递增的,求最大值同理。我们可以用两个数组储存值和标号,不会弄错。
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#define maxn 2000001
using namespace std;
int n,k;
int q[maxn],a[maxn],p[maxn],mi[maxn];
void Getmin()
{
	int tail=0,head=1;
	memset(q,0,sizeof(q));
	memset(p,0,sizeof(p));
	memset(mi,0,sizeof(mi));
	for(int i=1;i<k;i++)
	{
		while(head<=tail&&q[tail]>=a[i])
			--tail;
		q[++tail]=a[i];
		p[tail]=i;
	}
	for(int i=k;i<=n;i++)
	{
		while(head<=tail&&q[tail]>=a[i])
			--tail;
		q[++tail]=a[i];
		p[tail]=i;
		while(p[head]<i-k+1) 	++head;
		mi[i-k+1]=q[head];
	}
		for(int i=1;i<n-k+1;i++)
		printf("%d ",mi[i]);printf("%d\n",mi[n-k+1]);
}

void Getmax()
{
	int tail=0,head=1;
	memset(q,0,sizeof(q));
	memset(p,0,sizeof(p));
	memset(mi,0,sizeof(mi));
	for(int i=1;i<k;i++)
	{
		while(head<=tail&&q[tail]<=a[i])
			--tail;
		q[++tail]=a[i];
		p[tail]=i;
	}
	for(int i=k;i<=n;i++)
	{
		while(head<=tail&&q[tail]<=a[i])
			--tail;
		q[++tail]=a[i];
		p[tail]=i;
		while(p[head]<i-k+1) 	++head;
		mi[i-k+1]=q[head];
	}
	for(int i=1;i<n-k+1;i++)
		printf("%d ",mi[i]);printf("%d\n",mi[n-k+1]);
}
int main()
{
	scanf("%d%d",&n,&k);
	for(int i=1;i<=n;i++)
		scanf("%d",&a[i]);
	Getmin();
	Getmax();
	return 0;
}

  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值