POJ 2823 (单调队列模板题)

Description

An array of size n ≤ 10 6 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1 3 -1] -3 5 3 6 7 -1 3
1 [3 -1 -3] 5 3 6 7 -3 3
1 3 [-1 -3 5] 3 6 7 -3 5
1 3 -1 [-3 5 3] 6 7 -3 5
1 3 -1 -3 [5 3 6] 7 3 6
1 3 -1 -3 5 [3 6 7] 3 7
Your task is to determine the maximum and minimum values in the sliding window at each position.

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

题意:给你n个数字,然后有个可以放k个数字的窗户,然后窗户从左往右移动,输出为两行,第一行输出窗户移动过程中的最小数,第二行输出窗户移动的最大值
思路:第一次做这种题,用的是单调队列,用线段树应该也可以,呃,学单调队列这个算法花了一天多,在博客搜的讲解都有点浅,所以花了很久才搞懂,如果你是初学这个算法的话建议你把数据带进去试试,慢慢就明白原理了,这是个板子题。提交的话用c++,G++会错,我也不知道为什么

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define M 1000005
using namespace std;
int n,k;
int v[M],s[M],q[M]; 
void getmax()
{
    int head=1,tail=0;
    for(int i=1;i<k;i++)
    {
        while(head<=tail&&s[tail]<=v[i]) tail--;
        s[++tail]=v[i];
        q[tail]=i;
    }
    for(int i=k;i<=n;i++)
    {
        while(head<=tail&&s[tail]<=v[i]) tail--;
        s[++tail]=v[i];
        q[tail]=i;
        if(q[head]<=i-k) head++; //if如果放到while上面的话提交会错,我也不太清楚为什么 
         printf("%d ",s[head]);
    }
    return ;
}
void getmin()
{
    int head=1,tail=0;
    for(int i=1;i<k;i++)
    {
        while(head<=tail&&s[tail]>=v[i]) tail--;
        s[++tail]=v[i];
        q[tail]=i;
    }
    for(int i=k;i<=n;i++)
    {
        while(head<=tail&&s[tail]>=v[i])tail--;
        s[++tail]=v[i];
        q[tail]=i;
        if(q[head]<=i-k) head++;
        printf("%d ",s[head]);
    }
    return ;
}

int main()
{
    scanf("%d%d",&n,&k);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&v[i]);
    }
    getmin();
     cout<<"\n";
     getmax();
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值