poj1273

Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 56468 Accepted: 21695

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.  
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.  
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.  

Input

The input includes several cases.  For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source


点击打开链接

题意:

赤裸裸的网络流题目。给定点数,边数,每条

边的容量,以及源点,汇点,求最大流。

可以用来当做网络流的入门题。

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define maxn 500
#define INF 100000000
int n, m, s, t;
int a[maxn];
int p[maxn];
int cap[maxn][maxn];
int flow[maxn][maxn];
int main()
 {
    while(~scanf("%d%d",&m,&n))
    {
     memset(cap,0,sizeof(cap));
     for(int i = 0; i < m; i++)
     {
        int u, v, c;
        scanf("%d%d%d", &u, &v, &c);
        cap[u][v] += c;
     }
      s = 1;
      t = n;
      int ans = 0;
      queue<int> q;
      memset(flow, 0, sizeof(flow));
      for(;;)
        {
        memset(a, 0, sizeof(a));
        a[s] = INF;
        q.push(s);
        while(!q.empty())   //bfs找增广路
        {
          int u = q.front(); 
          q.pop();
          for(int v = 1; v <= n; v++) if(!a[v] && cap[u][v]>flow[u][v])
          {                            //找到新节点V并入队
            p[v] = u; q.push(v);       
            if(a[u]<cap[u][v]-flow[u][v])   //s-v上最小残量
            a[v]=a[u];
            else
                a[v]=cap[u][v]-flow[u][v];
          }
        }
        if(a[t] == 0) break;         //找不到,则当前已经是最小残量
        for(int u = t; u != s; u = p[u])  //更新流量
        {
          flow[p[u]][u] += a[t];
          flow[u][p[u]] -= a[t];
        }
        ans += a[t]; //更新从S流出的总流量
      }
      printf("%d\n", ans);
}
  return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值