poj 1273

Drainage Ditches

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 12   Accepted Submission(s) : 7
Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50


求源点1到汇点m的最大流  ek算法


第一次最大流。。。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define ll long long

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int c[205][205],f[205][205];
        int vis[205],p[205];
        queue<int >q;
        memset(c,0,sizeof(c));  //c标记容量
        memset(f,0,sizeof(f));  //f标记流量
        for(int i=0;i<n;i++)
        {
            int aa,bb,cc;
            scanf("%d%d%d",&aa,&bb,&cc);
            if(aa!=bb)  
            c[aa][bb]+=cc;  //可能会有重复边
        }
        int ff=0;
        while(1)
        {
            memset(vis,0,sizeof(vis));  //记录当前点的流量
            memset(p,-1,sizeof(p));     //记录当前点的前驱
            vis[1]=INF;
            q.push(1);
            while(q.size())
            {
                int st=q.front();
                q.pop();
                for(int i=1;i<=m;i++)
                {
                    if(!vis[i]&&f[st][i]<c[st][i])
                    {
                        vis[i]=min(vis[st],c[st][i]-f[st][i]);      //流量为当前路径的最大流量或者为当前点的最大流量
                        p[i]=st;                                    //记录前驱
                        q.push(i);
                    }
                }
            }

            if(!vis[m]) break;

            for(int i=m;i!=1;i=p[i])  
            {
                f[p[i]][i]+=vis[m];
                f[i][p[i]]-=vis[m];
            }
            ff+=vis[m];
        }

        printf("%d\n",ff);
    }
}


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define ll long long

int main()
{
    int n,m;
    int t,tt=1;
    int c[205][205],f[205];
    bool vis[205];
    int p[205];
    queue<int >q;
    //scanf("%d",&t);
    while(~scanf("%d%d",&n,&m))
    {
        memset(c,0,sizeof(c));  //c标记容量
        for(int i=0; i<n; i++)
        {
            int aa,bb,cc;
            scanf("%d%d%d",&aa,&bb,&cc);
            //if(aa!=bb)
                c[aa][bb]+=cc;  //可能会有重复边
        }
        int ff=0;
        while(1)
        {
            memset(vis,false ,sizeof(vis));  //记录当前点的流量
            memset(p,-1,sizeof(p));          //记录当前点的前驱
            for(int i=1;i<=m;i++)
                f[i]=INF;
            vis[1]=true ;
            while(q.size()) q.pop();
            q.push(1);
            while(q.size())
            {
                int st=q.front();
                q.pop();
                if(st==m) break;
                for(int i=1; i<=m; i++)
                {
                    if(!vis[i]&&c[st][i]>0)
                    {
                        vis[i]=true ;
                        f[i]=min(f[st],c[st][i]);                   //流量为当前路径的最大流量或者为当前点的最大流量
                        p[i]=st;                                    //记录前驱
                        q.push(i);
                    }
                }
            }

            if(!vis[m]) break;
            //cout<<f[n]<<endl;

            int st=m;
            while(st!=1)
            {
                int ed=p[st];
                c[ed][st]-=f[m];    //正向边
                c[st][ed]+=f[m];    //反向边
                st=ed;
            }

            ff+=f[m];
        }

        printf("%d\n",ff);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值