南阳 A+B Problem II

题目103

A+B Problem II

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
来源

 

#include<stdio.h>
#include<string.h>
int main(){
     int test;
     int js1,js2,i,j,max,t;
     char str1[1010],str2[1010];
     scanf("%d",&test);
     for(t=1;t<=test;t++){
      scanf("%s %s",str1,str2);
      js1 = strlen(str1);
      js2 = strlen(str2);
          int num1[1010] = {0},num2[1010] = {0};
      for(i=0;i<js1;i++)
       num1[js1-1-i]=str1[i]-'0';
       for(i=0;i<js2;i++)
                num2[js2-1-i]=str2[i]-'0';
            //将字符串赋值给数组。
  if(js1<js2){
   int swap=js1;
   js1 = js2;
   js2 = swap;
  }
    //保证js1为最大的。
  for(i = 0;i <= js1;i++){
   num1[i] += num2[i];
   if(num1[i] > 9){
    num1[i] -= 10;
    num1[i+1]++;
   }
  }
  if(num1[js1]==0){
   printf("Case %d:\n%s + %s = ",t,str1,str2);
   for(i = js1-1;i >= 0;i--)
   printf("%d",num1[i]);
   printf("\n");
  }
  //判断最高位num1[js1]是否为零。
      else{
       printf("Case %d:\n%s + %s = ",t,str1,str2);
       for(i = js1;i >= 0;i--)
    printf("%d",num1[i]);
    printf("\n");
      }
     }
  return 0;
      
     }


用C做过了,但这里用JAVA实现了一下,果然很简单。
import java.math.*;
import java.util.*;
public class Main {


	/**
	 * @param args
	 */
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in=new Scanner(System.in);
		 int n=in.nextInt();
		 int i=1;
		while(n>0){
			BigInteger a=in.nextBigInteger();
			BigInteger b=in.nextBigInteger();
			System.out.println("Case "+i+":");
			System.out.println(a+" + "+b+" = "+a.add(b));
			n--;
			i++;
		}
		
	}


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值