hdu 1050 Moving Tables

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19314    Accepted Submission(s): 6595


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
  
  
10 20 30
 
/*题解:     题目大意是,房间布置 如同第一个表格(第二个表格没什么用),经理需要移动桌子(移动一次十分钟),     桌子可以同时移动(条件允许一次移动完毕也可以),但是不能共用走廊(形如表格一),问移动所有桌子最短所需的时间。     解题思路: 将每个房间初始化为零,开始的房间号是偶数的话,实际相当于从(房间号-1)处开始,结束的房间号是奇数的话,实际相当于从(房间号+1)处开始。 两个房间进行一次操作,途经的所有房间都要++。最后输出最大数,即为最短时间。 提醒:注意比较房间大小 */
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int cmp(int a,int b)
{
    return a>b;
}
int main(){
    int T,n,i,j,a[410],st,end;
    scanf("%d",&T);
    while(T--){
        memset(a,0,sizeof(a));
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            scanf("%d %d",&st,&end);
            if(st>end)              //不比较会Wrong 
            {
                int t=st;
                st=end;
                end=t;
            }
            if(st%2==0) st--;
            if(end%2==1) end++;
            for(j=st; j<=end; j++)
                a[j]++;
        }
        sort(a,a+405,cmp);
        printf("%d\n",a[0]*10);
    }
    return 0;
}       


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值