POJ 2553-The Bottom of a Graph

Description

We will use the following (standard) definitions from graph theory. Let V be a nonempty and finite set, its elements being called vertices (or nodes). Let E be a subset of the Cartesian product V×V, its elements being called edges. Then G=(V,E) is called a directed graph.
Let n be a positive integer, and let p=(e1,...,en) be a sequence of length n of edges ei∈E such that ei=(vi,vi+1) for a sequence of vertices (v1,...,vn+1). Then p is called a path from vertex v1 to vertex vn+1 in G and we say that vn+1 is reachable from v1, writing (v1→vn+1).
Here are some new definitions. A node v in a graph G=(V,E) is called a sink, if for every node w in G that is reachable from v, v is also reachable from w. The bottom of a graph is the subset of all nodes that are sinks, i.e., bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.

Input

The input contains several test cases, each of which corresponds to a directed graph G. Each test case starts with an integer number v, denoting the number of vertices of G=(V,E), where the vertices will be identified by the integer numbers in the set V={1,...,v}. You may assume that 1<=v<=5000. That is followed by a non-negative integer e and, thereafter, e pairs of vertex identifiers v1,w1,...,ve,we with the meaning that (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.

题目大意:

给出一个有向图G=(V,E),其中1<=V<=5000,E<=V×V。定义一个图G的“bottom”为:图中所有“其余点均可到达自己”的点。
输出图的“bottom”。
输入有多组数据:
每组数据第一行为V和E,第二行有E对(x,y),表示有一条x到y的边。
输入数据以输入一个0结束。

Output

For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.

Sample Input

3 3
1 3 2 3 3 1
2 1
1 2
0

Sample Output

1 3
2

 

题解

强连通分量,按升序输出入度为0的强连通分块中所有点。看懂题目就可。

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int n,m,zz,head[5002];
struct bian{int to,nx;} e[25000002];
int sccnum[5002],pre[5002],low[5002],scc,ct;
int stack[5002],top;
int out[5002];
void insert(int x,int y)
{zz++; e[zz].to=y; e[zz].nx=head[x]; head[x]=zz;}
void init()
{
	scanf("%d",&m);
	int i,x,y;
	zz=0;
	memset(head,0,sizeof(head));
	for(i=1;i<=m;i++)
	   {scanf("%d%d",&x,&y);
	    insert(x,y);
	   }
}
void dfs(int x)
{
	pre[x]=low[x]=++ct;
	stack[++top]=x;
	int i,p;
	for(i=head[x];i;i=e[i].nx)
	   {p=e[i].to;
	    if(!pre[p])
	       {dfs(p); low[x]=min(low[x],low[p]);}
	    else if(!sccnum[p])
	       low[x]=min(low[x],pre[p]);
	   }
	p=-1;
	if(pre[x]==low[x])
	   {scc++;
	    while(p!=x)
	       {p=stack[top]; top--;
	        sccnum[p]=scc;
		   }
	   }
}
void targan()
{
	memset(sccnum,0,sizeof(sccnum));
	memset(pre,0,sizeof(pre));
	//memset(low,0,sizeof(low));
	ct=scc=top=0;
	int i;
	for(i=1;i<=n;i++)
	   {if(!pre[i]) dfs(i);}
}
void check()
{
	int i,j,p,tag=0;
	memset(out,0,sizeof(out));
	for(i=1;i<=n;i++)
	for(j=head[i];j;j=e[j].nx)
	   {p=e[j].to;
	    if(sccnum[i]!=sccnum[p]) out[sccnum[i]]++;
	   }
	for(i=1;i<=n;i++)
	   {p=sccnum[i];
	    if(!out[p])
		   {if(tag==0)
		       {printf("%d",i); tag=1;}
		    else printf(" %d",i);
		   }
	   }
	printf("\n");
}
int main()
{
	while(scanf("%d",&n)&&n)
	   {init();
	    targan();
	    check();
	   }
	return 0;
} 

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值