The Bottom of a Graph POJ 2553

12 篇文章 0 订阅

Description

We will use the following (standard) definitions from graph theory. Let V be a nonempty and finite set, its elements being called vertices (or nodes). Let E be a subset of the Cartesian product V×V, its elements being called edges. Then G=(V,E) is called a directed graph.
Let n be a positive integer, and let p=(e1,...,en) be a sequence of length n of edges ei∈E such that ei=(vi,vi+1) for a sequence of vertices (v1,...,vn+1). Then p is called a path from vertex v1 to vertex vn+1 in G and we say that vn+1 is reachable from v1, writing (v1→vn+1).
Here are some new definitions. A node v in a graph G=(V,E) is called a sink, if for every node w in G that is reachable from v, v is also reachable from w. The bottom of a graph is the subset of all nodes that are sinks, i.e., bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.

Input

The input contains several test cases, each of which corresponds to a directed graph G. Each test case starts with an integer number v, denoting the number of vertices of G=(V,E), where the vertices will be identified by the integer numbers in the set V={1,...,v}. You may assume that 1<=v<=5000. That is followed by a non-negative integer e and, thereafter, e pairs of vertex identifiers v1,w1,...,ve,we with the meaning that (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.

Output

For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.

Sample Input

3 3
1 3 2 3 3 1
2 1
1 2
0

Sample Output

1 3
2

题意:找缩点后出度为0的所有强连通分量,把属于这些强连通分量的点都排序后输出

思路:就直接tarjan缩点,然后找出度为0的点就好了,直接模板上,几分钟就写完ac

#include <cstdio>
#include<iostream>
#include <cstring>
#include <algorithm>
#include <stack>
using namespace std;
#define ll long long
const int maxn=2e5;
stack<int>q;
int cnt,n,m,head[maxn],dfn[maxn],low[maxn],co[maxn],tot,id,out[maxn],a[maxn],ans[maxn];
struct Edge
{
    int to,next;
}e[maxn];
void add(int u,int v)
{
    e[cnt].to=v;
    e[cnt].next=head[u];
    head[u]=cnt++;
}
void init()
{
    memset(out,0,sizeof(out));
    memset(co,0,sizeof(co));
    memset(head,-1,sizeof(head));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    while(!q.empty()) q.pop();
    cnt=0;id=0,tot=0;
}
void tarjan(int u)
{
    q.push(u);
    dfn[u]=low[u]=++tot;
    for(int i=head[u];i!=-1;i=e[i].next)
    {
        int v=e[i].to;
        if(!dfn[v])
        {
            tarjan(v);
            low[u]=min(low[u],low[v]);
        }
        else if(!co[v])
            low[u]=min(low[u],dfn[v]);
    }
    if(low[u]==dfn[u])
    {
        id++;
        while(q.top()!=u)
        {
            int x=q.top();
            q.pop();
            co[x]=id;
        }
        co[u]=id;
        q.pop();
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        scanf("%d",&m);
        init();
        for(int i=1;i<=m;i++)
        {
            int u,v;
            scanf("%d %d",&u,&v);
            add(u,v);
        }
        for(int i=1;i<=n;i++)
        {
            if(dfn[i]==0)
            {
                tarjan(i);
            }
        }
        for(int u=1;u<=n;u++)
        {
            for(int i=head[u];i!=-1;i=e[i].next)
            {
                int v=e[i].to;
                if(co[u]!=co[v])
                {
                    out[co[u]]++;
                }
            }
        }
        int num=0;
        for(int i=1;i<=n;i++)
        {
            if(out[co[i]]==0) ans[++num]=i;
        }
        sort(ans+1,ans+1+num);
        for(int i=1;i<=num;i++)
        {
            if(i==num) printf("%d\n",ans[i]);
            else printf("%d ",ans[i]);
        }
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值