UVA - 562 - Dividing coins (01背包)

UVA - 562

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

It's commonly known that the Dutch have invented copper-wire. Two Dutch men were fighting over a nickel, which was made of copper. They were both so eager to get it and the fighting was so fierce, they stretched the coin to great length and thus created copper-wire.


Not commonly known is that the fighting started, after the two Dutch tried to divide a bag with coins between the two of them. The contents of the bag appeared not to be equally divisible. The Dutch of the past couldn't stand the fact that a division should favour one of them and they always wanted a fair share to the very last cent. Nowadays fighting over a single cent will not be seen anymore, but being capable of making an equal division as fair as possible is something that will remain important forever...


That's what this whole problem is about. Not everyone is capable of seeing instantly what's the most fair division of a bag of coins between two persons. Your help is asked to solve this problem.


Given a bag with a maximum of 100 coins, determine the most fair division between two persons. This means that the difference between the amount each person obtains should be minimised. The value of a coin varies from 1 cent to 500 cents. It's not allowed to split a single coin.

Input 

A line with the number of problems  n, followed by  n times:
  • a line with a non negative integer m ($m \le 100$) indicating the number of coins in the bag
  • a line with m numbers separated by one space, each number indicates the value of a coin.

Output 

The output consists of  n lines. Each line contains the minimal positive difference between the amount the two persons obtain when they divide the coins from the corresponding bag.

Sample Input 

2
3
2 3 5
4
1 2 4 6

Sample Output 

0
1



Miguel A. Revilla
1998-03-10

Source

Root :: Competitive Programming: Increasing the Lower Bound of Programming Contests (Steven & Felix Halim) :: Chapter 3. Problem Solving Paradigms :: Dynamic Programming ::  0-1 Knapsack - Classical
Root :: AOAPC I: Beginning Algorithm Contests (Rujia Liu) ::  Volume 5. Dynamic Programming 
Root :: Competitive Programming 2: This increases the lower bound of Programming Contests. Again (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming ::  0-1 Knapsack (Subset Sum)
Root :: Competitive Programming 3: The New Lower Bound of Programming Contests (Steven & Felix Halim) :: Problem Solving Paradigms :: Dynamic Programming ::  0-1 Knapsack (Subset Sum)

 Status





思路:先算出m个硬币的总和sum,再取其一半su = sum/2作为背包的容量,看此时最多能够容纳多少硬币,即转化为背包问题


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int coin[105];
int dp[30005];	//没看清题RE了一次,最多有100*500/2,所以要开大点 

int main() {
	int n, m;
	scanf("%d", &n);
	while(n--) {
		scanf("%d", &m);
		int sum = 0;
		for(int i = 0; i < m; i++) {
			scanf("%d", &coin[i]);
			sum += coin[i];
		}
		int su = sum / 2;
		
		memset(dp, 0, sizeof(dp));
		for(int i = 0; i < m; i++) {
			for(int j = su; j >= coin[i]; j--) {
				dp[j] = max(dp[j], dp[j - coin[i]] + coin[i]);
			}
		}
		
		printf("%d\n", sum - 2 * dp[su]);
	}
	return 0;
} 













  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值