HDU-4438-Hunters

Hunters

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1107    Accepted Submission(s): 850


Problem Description
Alice and Bob are the topmost hunters in the forest, so no preys can escape from them. However, they both think that its hunting skill is better than the other. So they need a match.
In their match, the targets are two animals, a tiger and a wolf. They both know that the tiger is living in the south of the forest and the wolf is living in the north of the forest. They decide that the one who kills the tiger scores X points and who kills the wolf scores Y points. If the one who kills both tiger and wolf scores X+Y points.
Before the match starts, Alice is in the east of the forest and Bob is in the west of the forest. When the match starts, Alice and Bob will choose one of the preys as targets. Because they haven't known the other's choice, maybe they choose the same target. There will be two situations:
(1) If they choose different targets, they both are sure of killing their respective targets.
(2) If they choose the same target, the probability of Alice killing the target is P, and the probability of Bob killing it is 1-P. Then they will hunt for the other prey, also the probability of Alice killing it is P and the probability of Bob killing it is 1-P.
But Alice knows about Bob. She knows that the probability of Bob choosing tiger as his first target is Q, and the probability of choosing wolf is 1-Q. So that Alice can decide her first target to make her expected score as high as possible.
 

Input
The first line of input contains an integer T (1≤T≤10000), the number of test cases.
Then T test cases follow. Each test case contains X, Y, P, Q in one line. X and Y are integers and 1≤X, Y≤1000000000. P and Q are decimals and 0≤P, Q≤1, and there are at most two digits after decimal point.
 

Output
For each test case, output the target Alice should choose and the highest expected score she can get, in one line, separated by a space. The expected score should be rounded to the fourth digit after decimal point. It is guaranteed that Alice will have different expected score between choosing tiger and wolf.
 

Sample Input
  
  
3 2 1 0.5 0.5 2 1 0 1 7 7 0.32 0.16
 

Sample Output
  
  
tiger 1.7500 wolf 1.0000 tiger 6.5968
 

Source
 



绝对水题!!

就是两个期望值!!

不过陷在浮点数陷阱里错了一次!!

以后注意浮点数不能直接相等!!


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int main()
{
	int T;
	double x, y, p, q;
	scanf("%d", &T);
	while(T--)
	{
		scanf("%lf %lf %lf %lf", &x, &y, &p, &q);
		double ans1 = q*(x*p+y*p) + (1-q)*x, ans2 = (1-q)*(x*p+y*p) + q*y;
		if(ans1 > ans2)printf("tiger %.4lf\n", ans1);
		else printf("wolf %.4lf\n", ans2);
	}
	return 0;
} 



AC代码(之前没注意浮点数陷阱错了一次):

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define max(a,b) (a)>(b)?(a):(b)
using namespace std;

int main()
{
    int T, x, y;
    double p, q;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d %d %lf %lf", &x, &y, &p, &q);
        double ans1=q*(x*p+y*p) + (1-q)*x, ans2=(1-q)*(x*p+y*p) + q*y;
        double ans = max(ans1, ans2);
        if(ans-ans1<1e-6)printf("tiger ");  //不能写ans==ans1,会产生浮点数误差!! 
        else printf("wolf ");
        printf("%.4lf\n", ans);
    }
    return 0;
} 



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值