HDU 2377 基础dijkstra,spfa算法

先贴题目:

You travel a lot by bus and the costs of all the seperate tickets are starting to add up.


Therefore you want to see if it might be advantageous for you to buy a bus pass.

The way the bus system works in your country (and also in the Netherlands) is as follows:

when you buy a bus pass, you have to indicate a center zone and a star value. You are allowed to travel freely in any zone which has a distance to your center zone which is less than your star value. For example, if you have a star value of one, you can only travel in your center zone. If you have a star value of two, you can also travel in all adjacent zones, et cetera.

You have a list of all bus trips you frequently make, and would like to determine the minimum star value you need to make all these trips using your buss pass. But this is not always an easy task. For example look at the following figure:



Here you want to be able to travel from A to B and from B to D. The best center zone is 7400, for which you only need a star value of 4. Note that you do not even visit this zone on your trips!

Input
On the first line an integert(1 <=t<= 100): the number of test cases. Then for each test case:

One line with two integersnz(2 <=nz<= 9 999) andnr(1 <=nr<= 10): the number of zones and the number of bus trips, respectively.

nz lines starting with two integers id i (1 <= id i <= 9 999) and mz i (1 <= mz i <= 10), a number identifying the i-th zone and the number of zones adjacent to it, followed by mz i integers: the numbers of the adjacent zones.

nr lines starting with one integer mr i (1 <= mr i <= 20), indicating the number of zones the ith bus trip visits, followed by mr i integers: the numbers of the zones through which the bus passes in the order in which they are visited.

All zones are connected, either directly or via other zones.

 

Output
For each test case:

One line with two integers, the minimum star value and the id of a center zone which achieves this minimum star value. If there are multiple possibilities, choose the zone with the lowest number.

 

Sample Input
  
  
1 17 2 7400 6 7401 7402 7403 7404 7405 7406 7401 6 7412 7402 7400 7406 7410 7411 7402 5 7412 7403 7400 7401 7411 7403 6 7413 7414 7404 7400 7402 7412 7404 5 7403 7414 7415 7405 7400 7405 6 7404 7415 7407 7408 7406 7400 7406 7 7400 7405 7407 7408 7409 7410 7401 7407 4 7408 7406 7405 7415 7408 4 7409 7406 7405 7407 7409 3 7410 7406 7408 7410 4 7411 7401 7406 7409 7411 5 7416 7412 7402 7401 7410 7412 6 7416 7411 7401 7402 7403 7413 7413 3 7412 7403 7414 7414 3 7413 7403 7404 7415 3 7404 7405 7407 7416 2 7411 7412 5 7409 7408 7407 7405 7415 6 7415 7404 7414 7413 7412 7416
 

Sample Output
  
  
4 7400
今天被这道题坑的太惨了,一直是wa,最后看了别人的代码才发现,原来少了一个排序的过程,如果相同的结果需要输出小的,总得来说,这道题肯定不能用邻接矩阵,否则会有哦o(nz^2)的时间复杂度,这样就肯定会tlo(我没试过),然后就会想到用邻接表的方法,这样就ok了,还有就是INF的值,要比较小才行,我原来很大,也是wa,该校以后就ok了(不知道为什么,有大神看出来告诉我一下),我的基本思路就是用后来的每一个站点去找到每区的最小值,然后找出所有这些站点到其中一个区的最大值,然后再比较这些最大值的最小值

下面贴代码:

#include<cstdio>
#include<cstring>
#include<queue>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <iostream>
using namespace std;
const int MAXN = 10005;
int nz,nr;
int INF = 100;
int id[MAXN],head[MAXN],dist[MAXN],maxid[MAXN];
bool vis[MAXN];
struct  edge
{
    int u,v;
    int next;
}   edge[200005];
int cnt;
void add(int u,int v) / /这步把所有与u有关的节点连起来
{
    edge[cnt].u=u;
    edge[cnt].v=v;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
void spfa(int st) // 模板代码
{
    memset(vis,0,sizeof(vis));
    memset(dist,INF,sizeof(dist));
    queue <int> q;
    q.push(st);
    dist[st]=0;
    vis[st]=true;
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            int v=edge[i].v;
                if(dist[v]>dist[u]+1)
                {
                    dist[v]=dist[u]+1;
                    if(!vis[v])
                    {
                        q.push(v);
                        vis[v]=true;
                    }
                }
        }
    }
}
int main()
{
    freopen("test.txt","r",stdin);
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&nz,&nr);
        memset(maxid,0,sizeof(maxid));
        memset(head,-1,sizeof(head));
        cnt=0;
        for(int i=0;i<nz;i++)
        {
            int mz;
            scanf("%d%d",&id[i],&mz);
            while(mz--)
            {
                int v;
                scanf("%d",&v);
                add(id[i],v);
            }
        }
        while(nr--)
        {
            int mr;
            scanf("%d",&mr);
            while(mr--)
            {
                int st;
                scanf("%d",&st);
                spfa(st);
                for(int i=0;i<nz;i++)
                {
                    if(dist[id[i]]>maxid[id[i]])
                        maxid[id[i]]=dist[id[i]];
                }
            }
        }
        int mindist=1000000,k;
        sort(id,id+nz);//就是这步,一开始我没加,真是害惨我了
        for(int i=0;i<nz;i++)
        {
            if(maxid[id[i]]<mindist)
            {
                mindist=maxid[id[i]];
                k=id[i];
            }
        }
        printf("%d %d\n",mindist+1,k);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值