1025. PAT Ranking (25)

102 篇文章 0 订阅
37 篇文章 0 订阅

1025. PAT Ranking (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
输入N  N个地区
接着每个地区K  对应K个帐号和他的分数;

我这里用动态数组vector可以不断的把所有地区的id,score,location加入(.push_back) 到ranklist中,
输入结束,全体sort获得非升vector 的ranklist;
接着每个定义最高分sc为101.对应的排名rank为0,分数为101的count为0个;
利用 final_rank(int*sc,int*finalrank,int*finalCount,int score)获得对应的总排名。区域排名

#include<string>  string 直接进行比较,直接string间互相赋值;
用到了vector,sort
  
  
vector 介绍http://www.cnblogs.com/panxiaoyu/archive/2012/03/10/acm.html

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
7月30日 20:49答案正确251025C++ (g++ 4.7.2)953500datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确118013/13
1答案正确13086/6
2答案正确13083/3
3答案正确9535003/3
#include<iostream>  
#include<vector>
#include<string>
#include<algorithm>
using namespace std;  
struct rankingpat
{
  string id;
  int score;
  int location;
  rankingpat(string i, int s, int l) :id(i), score(s), location(l){}
};
bool RankCmP(const rankingpat&A, const rankingpat&B)
{
  if (A.score != B.score)return A.score > B.score;
  return A.id < B.id;
}
int  final_rank(int*sc,int*finalrank,int*finalCount,int score)
{
  if ((*sc) == score)(*finalCount)++;
  else 
  {
    (*finalrank) += (*finalCount);
    (*finalCount) = 1;
    (*sc) = score; 
  }
  return (*finalrank) + 1;
}
template<typename T_T>
void StarCle(T_T*V, int STart, int END, T_T des)
{
  while (STart < END)
  {
    V[STart++] = des;
  }
}
int main()
{     
  vector<rankingpat>ranklist;
  int*locationCount, *locationrank,*locationScore;
  int finalrank,finalCount;
  int  index, N, K, tag,temp,sc; 
  string Idn;
  cin >> N;
  locationCount = new int[N];
  locationrank = new int[N];
  locationScore = new int[N];
  StarCle(locationCount, 0, N, 0);
  StarCle(locationrank, 0, N, 0);
  StarCle(locationScore, 0,N, 101);
  for (index = 0, temp = 0; index < N; index++)
  {
    cin >> K;
    temp += K; 
    
    for (tag = 0; tag < K; tag++)
    {
      cin >> Idn >> sc;
      ranklist.push_back(rankingpat(Idn, sc, index));
    }
  }
  sort(ranklist.begin(), ranklist.end(), RankCmP);
  cout << temp << endl;
  sc = 101;
  finalCount = finalrank = 0; 
  for (index = 0; index < temp; index++)
  {
    cout << ranklist[index].id << " ";
    tag = ranklist[index].location;
    cout << final_rank(&sc, &finalrank, &finalCount, ranklist[index].score) << " " << tag+1<<" "; 
    cout << final_rank(&locationScore[tag], &locationrank[tag], &locationCount[tag], ranklist[index].score) << endl;
  }
  delete[]locationScore; 
  delete[]locationrank;
  delete[]locationCount;
  system("pause");   
  return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值