第四届 山东省ACM Rescue The Princess(计算几何)

Rescue ThePrincess

Time Limit:1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

    Several daysago, a beast caught a beautiful princess and the princess was put in prison. Torescue the princess, a prince who wanted to marry the princess set outimmediately. Yet, the beast set a maze. Only if the prince find out the maze’sexit can he save the princess.

    Now, here comes theproblem. The maze is a dimensional plane. The beast is smart, and he hidden theprincess snugly. He marked two coordinates of an equilateral triangle in the maze. The two markedcoordinates are A(x1,y1) and B(x2,y2).The third coordinate C(x3,y3) is the maze’s exit. If theprince can find out the exit, he can save the princess. After the prince comesinto the maze, he finds out the A(x1,y1) and B(x2,y2),but he doesn’t know where the C(x3,y3) is. The princeneed your help. Can you calculate the C(x3,y3) and tell him?

输入

    The first line is aninteger T(1 <= T <= 100) which is the number of test cases. T test casesfollow. Each test case contains two coordinates A(x1,y1)and B(x2,y2), described by four floating-point numbers x1,y1, x2, y2( |x1|, |y1|,|x2|, |y2| <= 1000.0).
    Please notice that A(x1,y1) and B(x2,y2)and C(x3,y3) are in an anticlockwise direction fromthe 
equilateral triangle. Andcoordinates A(x1,y1) and B(x2,y2)are given by anticlockwise.

输出

   For each test case, you should output the coordinate of C(x3,y3),the result should be rounded to 2 decimal places in a line.

示例输入

4

-100.00 0.00 0.000.00

0.00 0.00 0.00100.00

0.00 0.00 100.00100.00

1.00 0.00 1.8660.50

示例输出

(-50.00,86.60)

(-86.60,50.00)

(-36.60,136.60)

(1.00,1.00)

提示

 

来源

2013年山东省第四届ACM大学生程序设计竞赛

示例程序

推广结论:对于任意两个不同点ABAB旋转θ角度后的坐标为:

(Δx*cosθ- Δy * sinθ+ xB, Δy*cosθ + Δx * sinθ+ yB ) 


#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdio>
#include<math.h>
using namespace std;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        double x1,x2,y1,y2,x3,y3,x,y;
        scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
        x=x2-x1;
        y=y2-y1;
        x3=x/2-y*sqrt(3)/2+x1;
        y3=y/2+x*sqrt(3)/2+y1;
        printf("(%.2f,%.2f)\n",x3,y3);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值