第四届 山东省ACM A^X mod P (分解优化=哈希+打表)

A^X mod P

Time Limit: 5000MS Memory Limit: 65536KB
Problem Description

It's easy for ACMer to calculate A^X mod P. Now given seven integers n, A, K, a, b, m, P, and a function f(x) which defined as following.

f(x) = K, x = 1

f(x) = (a*f(x-1) + b)%m , x > 1


Now, Your task is to calculate

( A^(f(1)) + A^(f(2)) + A^(f(3)) + ...... + A^(f(n)) ) modular P. 

Input
 In the first line there is an integer T (1 < T <= 40), which indicates the number of test cases, and then T test cases follow. A test case contains seven integers n, A, K, a, b, m, P in one line.

1 <= n <= 10^6

0 <= A, K, a, b <= 10^9

1 <= m, P <= 10^9

Output
 For each case, the output format is “Case #c: ans”. 

c is the case number start from 1.

ans is the answer of this problem.

Example Input
23 2 1 1 1 100 1003 15 123 2 3 1000 107
Example Output
Case #1: 14Case #2: 63
Hint
Author
2013年山东省第四届ACM大学生程序设计竞赛


题意:

题目意思很简单,就是求(A^f[1]+A^f[2]+。。。+A^f[n])%P

题解:

一开始直接扫描一遍结果无情TL,用快速幂计算幂值有很多重复的计算,因此想办法将结果保存在数组里面,dp的思想。显然f[i]=fix*k+j,这样分解是对的,那么选取一个合适的fix,这样数组可以存下需要的解。不妨令fix=31623

,那么A^(fix*k+j)%m,就可以分解成(A^k)^fix*A^j,用dpk[i]保存(A^k)^i,dpj[i]保存A^i,那么

A^f[i]=dpk[i/fix]*dpj[i%fix];


#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double pi= acos(-1.0);
const int maxn=33333;
LL  X[maxn+10],Y[maxn+10];
LL n,A,K,a,b,m,P;
void Init()
{
    int i;
    X[0]=1;
    for(i=1;i<=maxn;i++){
        X[i]=(X[i-1]*A)%P;
    }
    LL tmp=X[maxn];
    Y[0]=1;
    for(i=1;i<=maxn;i++){
        Y[i]=(Y[i-1]*tmp)%P;
    }
}
void Solve(int icase)
{
    int i;
    LL fx=K;
    LL res=0;
    for(i=1;i<=n;i++){
        res=(res+(Y[fx/maxn]*X[fx%maxn])%P)%P;
        fx=(a*fx+b)%m;
    }
   printf("Case #%d: %lld\n",icase,res);
}

int main()
{
    int T,icase;
    scanf("%d",&T);
    for(icase=1;icase<=T;icase++){
        scanf("%lld %lld %lld %lld %lld %lld %lld",&n,&A,&K,&a,&b,&m,&P);
        Init();
        Solve(icase);
    }
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值