A^X mod P 大幂分解求和 打表



It's easy for ACMer to calculate A^X mod P. Now given seven integers n, A, K, a, b, m, P, and a function f(x) which defined as following.

f(x) = K, x = 1

f(x) = (a*f(x-1) + b)%m , x > 1




Now, Your task is to calculate

( A^(f(1)) + A^(f(2)) + A^(f(3)) + ...... + A^(f(n)) ) modular P.


Input


In the first line there is an integer T (1 < T <= 40), which indicates the number of test cases, and then T test cases follow. A test case contains seven integers n, A, K, a, b, m, P in one line.
1 <= n <= 10^6

0 <= A, K, a, b <= 10^9

1 <= m, P <= 10^9


Output


For each case, the output format is “Case #c: ans”.
c is the case number start from 1.

ans is the answer of this problem.


Sample Input

2
3 2 1 1 1 100 100
3 15 123 2 3 1000 107


Sample Output

Case #1: 14
Case #2: 63


#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <algorithm>
#include <vector>
#include <map>
#include <string>
#include <stack>
#define LL long long
#define INF 0x7fffffff
#define maxn 33333
#define PI 3.1415926535897932
#define E 2.718281828459045
using namespace std;
long long t,n,A,K,a,b,m,p;
long long X[maxn+10],Y[maxn+10];   //x[maxn]里面存着A^(1到maxn) y[maxn]里面存着 A^(maxn=10000000000多)次方  将表拆开进行记录
void init()  //打表;
{
    int i;
    X[0]=1;
    for(i=1;i<=maxn;i++){
        X[i]=(X[i-1]*A)%p;
    }
    Y[0]=1;
    long long ans=X[maxn];
    for(i=1;i<=maxn;i++){
        Y[i]=(Y[i-1]*ans)%p;
    }
}
int main()
{
    int cases=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d%I64d%I64d%I64d%I64d%I64d%I64d",&n,&A,&K,&a,&b,&m,&p);
        init();
        long long sum=0;
        for(long long i=1;i<=n;i++){
            sum=(sum+(X[K%maxn]*Y[K/maxn])%p)%p;  //把K分解
            K=(a*K+b)%m;
        }
        cout<<"Case #"<<cases<<": "<<sum<<endl;
        cases++;
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值