Apple Tree - POJ 3321 树状数组+离散化+N叉树

Apple Tree
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 17962 Accepted: 5450

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2


题意:先给你每次节点的连接方式,一开始每个节点上都有苹果,然后问你某个节点及其子树一共有多少个苹果,期间某个节点的苹果可能会被摘下,或又长出来。

思路:dfs离散化,如果网上其他的题解看不懂是怎么建树的话,我这个方法应该比较容易懂。

          先说一下如何建树。

        比如                   1                 这棵树(对应一下),变成                    1

                     2            3          4                                                      2            5          9

                 5    6        7   8        9                                                 3    4        6   8        10

                                10                                                                              7 

         这样类似于先序的排列。

         然后比如问改后的5节点,就是5-8的和,1就是1-10的和。

         我是struct node { }其中的u和v代表父子连接方式然后按照u第一元素从小到大,v第二元素从小到大排序后放在数组里,这样方便记录某个节点下有哪些子节点。注意每个节点下可能有多个子节点……最开始因为这个WA了无数次。

AC代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{ int val,u,v,sonnum,begin,max;//val有无苹果,uv父子节点,sonnum子节点数量,
                               //begin,num2[]中从哪个开始时它的连接方式
                               //max记录某个点下面最大的子节点是多少,用于树状数组求和
}tree[100010];   //tree[]一做两用,排序uv和记录某个节点下有哪些子节点
int a[100010];
int num1[100010];
int num2[100010];
int n,m,pos,u,v;
char s[10];
int lowbit(int x)
{ return x&(-x);
}
void update(int x,int val)
{ while(x<=100000)
  { a[x]+=val;
    x+=lowbit(x);
  }
}
int sum(int x)
{ int ret=0;
  while(x)
  { ret+=a[x];
    x-=lowbit(x);
  }
  return ret;
}
bool cmp(node a,node b)
{ if(a.u<b.u)
   return true;
  else if(a.u==b.u)
    return a.v<b.v;
  else
    return false;
}
void dfs(int k)
{ num1[k]=++pos;
  for(int i=tree[k].begin;i<tree[k].begin+tree[k].sonnum;i++)//从左到右dfs
   dfs(num2[i]);
  tree[k].max=pos;//记录某个点下面最大的子节点是多少,用于树状数组求和
}
int main()
{ int k,i,j,father,ans=0,num;
   scanf("%d",&n);
  for(i=1;i<=n;i++)
  { update(i,1);tree[i].val=1;}
  for(i=1;i<n;i++)
   scanf("%d%d",&tree[i].u,&tree[i].v);
  sort(tree+1,tree+n,cmp);
  father=1;
  tree[1].begin=1;
  for(i=1;i<n;i++)
  { if(tree[i].u==father)
    { tree[father].sonnum++;
      num2[i]=tree[i].v;
    }
    else
    { father=tree[i].u;
      tree[father].begin=i;
      tree[father].sonnum++;
      num2[i]=tree[i].v;
    }
  }
  pos=0;
  dfs(1);
  scanf("%d",&m);
  for(j=1;j<=m;j++)
  { scanf("%s",s);
    scanf("%d",&k);
    if(s[0]=='Q')
    { ans=sum(tree[k].max)-sum(num1[k])+tree[k].val;
      printf("%d\n",ans);
    }
    else
    { if(num1[k]!=0)
      if(tree[k].val==1)
      { update(num1[k],-1);
        tree[k].val=0;
      }
      else
      { update(num1[k],1);
        tree[k].val=1;
      }
    }
  }
}



1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
POJ 2182是一道使用树状数组解决的题目,题目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问题的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成题目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值