MooFest
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 4925 | Accepted: 2087 |
Description
Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing.
Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)).
Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume.
Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows.
Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)).
Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume.
Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows.
Input
* Line 1: A single integer, N
* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location.
* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location.
Output
* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows.
Sample Input
4 3 1 2 5 2 6 4 3
Sample Output
57
直接借鉴程学长的讲解了。
题意抽象:
在数轴上有一列互不相同点xN(
1 <= N <= 20,000 , 1 <= xi <= 20,000 ),每个点有一个权值vi(1 <= vi <= 20,000),
对每对点xi,xj,算出|xi - xj| * max{vi,vj},然后求这些结果的和。
思路:
1. 首先将这n个点按照v值从小到大排序(后面说的排在谁的前面,都是基于这个排序)。
这样,当i<j时有max{vi,vj}=vj,
2. 用两个树状数组,一个记录比xi小的点的个数a,一个记录比xi小的点的位置之和b,
然后,我们可以快速地求出xi与比xi小的点的所有距离的绝对值之和:a*x[i]-b,
也可以方便地求出xi与比xi大的点的所有距离的绝对值之和:所有距离-b-(i-1-a)*x[i]。
将二者相加,乘上vi,再把所有结果相加,搞定。
然后附上我的AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
int n=20000;
int c[20010];
int d[20010];
int lowbit(int x)
{ return x&(-x);
}
void update(int x)
{ int date=x;
for(;x<=n;x+=lowbit(x))
{d[x]+=date;
c[x]++;
}
}
int sum(int x)
{ int ans=0;
for(;x>0;x-=lowbit(x))
ans+=c[x];
return ans;
}
int sum2(int x)
{ int ans=0;
for(;x>0;x-=lowbit(x))
ans+=d[x];
return ans;
}
struct cow
{ int v,x;
}st[20010];
bool cmp(cow a,cow b)
{ if(a.v!=b.v)
return a.v<b.v;
else
return a.x<b.x;
}
int main()
{ int t,v,x,i;
long long a,b,e,f;
scanf("%d",&t);
for(i=1;i<=t;i++)
scanf("%d%d",&st[i].v,&st[i].x);
sort(st+1,st+t+1,cmp);
memset(c,0,sizeof(c));
memset(d,0,sizeof(d));
long long an=0;
for(i=1;i<=t;i++)
{ v=st[i].v;
x=st[i].x;
a=sum(x);
b=sum(20000)-a;
e=sum2(x);
f=sum2(20000)-e;
an+=v*(x*(a-b)-e+f);
update(x);
}
printf("%lld\n",an);
return 0;
}