POJ 2528 Mayor's posters(线段树+离散化)

Language:
Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 43702 Accepted: 12763

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source



题意:贴海报,后面的海报可以覆盖前面的海报,问你贴完后可以看到的海报数目(请注意是可以看到的海报)


思路:

    先离散化,然后从后向前查询,每查询一下,就把这个区间的海报标记被覆盖(这里可以lazy,但是记得pushdown())


在这里我贴出两份代码,第二份我bug了一些时间



第一份

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)
using namespace std;
#define N 100100

int a[N*2];
int h[10000005];

struct stud{
int le,ri;
}post[N];

struct stud1{
int le,ri;
int cover;
}f[N*4];


int cmp(int a,int b)
{
    return a<b;
}

void build(int pos,int le,int ri)
{
    f[pos].le=le;
    f[pos].ri=ri;
    f[pos].cover=0;
    if(le==ri) return ;

    int mid=MID(le,ri);

    build(L(pos),le,mid);
    build(R(pos),mid+1,ri);
}

int query(int pos,int le,int ri)
{

    if(f[pos].cover)
        return 0;

    if(f[pos].le==le&&f[pos].ri==ri)
    {
        f[pos].cover=1;
        return 1;
    }

    int result;

    int mid=(f[pos].le+f[pos].ri)/2;

    if(mid>=ri)
         result=query(L(pos),le,ri);
    else
        if(mid<le)
          result=query(R(pos),le,ri);
        else
          result=query(L(pos),le,mid)|query(R(pos),mid+1,ri);

    if(f[L(pos)].cover&&f[R(pos)].cover)
            f[pos].cover=1;

        return result;
}

int main()
{
    int i,n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int k=0;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&post[i].le,&post[i].ri);
            a[k++]=post[i].le;
            a[k++]=post[i].ri;
        }

        sort(a,a+k,cmp);

        k=unique(a,a+k)-a;

        for(i=0;i<k;i++)
            h[a[i]]=i;

        build(1,0,k-1);

        int ans=0;


        for(i=n-1;i>=0;i--)
            if(query(1,h[post[i].le],h[post[i].ri]))
                {
                    ans++;
                }

        printf("%d\n",ans);
    }
    return 0;
}



第二份:


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)
using namespace std;
#define N 100100

int ha[10000005];
int n,ans;
int a[N*2];

struct stud{
int le,ri;
}p[N];

struct studd{
int le,ri;
int cover;
}f[N*4];

void pushdown(int pos)
{
      if(f[pos].cover)
		f[L(pos)].cover=f[R(pos)].cover=f[pos].cover;
}

void build(int pos,int le,int ri)
{
	f[pos].le=le;
	f[pos].ri=ri;
	f[pos].cover=0;
	if(le==ri) return ;

	int mid=MID(le,ri);
	build(L(pos),le,mid);
	build(R(pos),mid+1,ri);
}

int query(int pos,int le,int ri)
{
    int result=0;


   // if(f[pos].cover)
       // return 0;      因为第二份没有这个,所以需要pushdown(pos);

	if(f[pos].le==le&&f[pos].ri==ri)
	{
		if(f[pos].cover==0)
	       result=1;
		else
			result=0;

		f[pos].cover=1;

		return result;
	}

	int mid=MID(f[pos].le,f[pos].ri);

     pushdown(pos);

     if(mid>=ri)
		result=query(L(pos),le,ri);
     else
		if(mid<le)
		result=query(R(pos),le,ri);
     else
	    result=query(L(pos),le,mid)|query(R(pos),mid+1,ri);

	if(f[L(pos)].cover&&f[R(pos)].cover)
		f[pos].cover=1;

	return result;

}

int main()
{
	int i,j,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		int k=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&p[i].le,&p[i].ri);
			a[k++]=p[i].le;
			a[k++]=p[i].ri;
		}

		sort(a,a+k);

		k=unique(a,a+k)-a;

		for(i=0;i<k;i++)
			ha[a[i]]=i;

		build(1,0,k-1);

		ans=0;

		for(i=n-1;i>=0;i--)
			if(query(1,ha[p[i].le],ha[p[i].ri]))
			  ans++;

		printf("%d\n",ans);
	}
	  return 0;
}







  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值