poj 2195 Going Home 二分图最大权匹配

                                                                              Going Home
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 14300
Accepted: 7333

Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28

通过这题学习了二分图最大权匹配。。。
其实是将这个变成子图的完备匹配。
有现成的KM算法,注意点数n<=m;
代码: 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>


using namespace std;
int const nMax = 210;

int map[nMax][nMax];
struct A
{
    int x,y;
};

A H[nMax],M[nMax];
int sx[nMax],sy[nMax];
int my[nMax];
int n,m;
char s[nMax][nMax];
int lx[nMax],ly[nMax];

bool find(int u){
    sx[u]=1;
    for(int v=1;v<=m;v++)if(!sy[v]&&(lx[u]+ly[v]==map[u][v])){
        sy[v]=1;
        if( my[v]==-1 || find(my[v]) ){
            my[v]=u;
            return true;
        }
    }
    return false;
}

int KM(){     //注意n<=m
    for(int i=1;i<=m;i++)ly[i]=0;
    for(int i=1;i<=n;i++){
        lx[i]=-0x7fffffff;
        for(int j=1;j<=m;j++)if(map[i][j]>lx[i])lx[i]=map[i][j];
    }//初始化
    memset(my,-1,sizeof(my));
    for(int u=1;u<=n;u++){
        while(1){
            memset(sx,0,sizeof(sx));
            memset(sy,0,sizeof(sy));
            if(find(u))break;
            int inc=0x7fffffff;
            for(int i=1;i<=n;i++)if(sx[i]){
                for(int j=1;j<=m;j++)if(!sy[j]&&((lx[i]+ly[j]-map[i][j])<inc))inc=lx[i]+ly[j]-map[i][j];
            }
            if(inc==0)puts("WA");
            for(int i=1;i<=n;i++)if(sx[i])lx[i]-=inc;
            for(int j=1;j<=m;j++)if(sy[j])ly[j]+=inc;
        }
    }
    int ans=0;
    for(int i=1;i<=m;i++)if(my[i]!=-1)ans+=map[my[i]][i];
    return -ans;
}

int a,b;
int main()
{
    while(~scanf("%d%d",&a,&b),a||b)
    {
        n=m=0;
        for(int i=0;i<a;i++)scanf("%s",s[i]);
        for(int i=0;i<a;i++){
            for(int j=0;j<b;j++){
                if(s[i][j]=='H'){
                    H[++n].x=i;
                    H[n].y=j;
                }else if(s[i][j]=='m'){
                    M[++m].x=i;
                    M[m].y=j;
                }
            }
        }
        memset(map,0,sizeof(map));
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                map[i][j]=-(abs(H[i].x-M[j].x)+abs(H[i].y-M[j].y));
      //  for(int i=1;i<=n;i++,puts(""))for(int j=1;j<=m;j++)printf("%d ",map[i][j]);
        int ans=KM();
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值