POJ 2371 Questions and answers(水~)

470 篇文章 3 订阅

Description
首先给出一个n,一下n行接着给n个数,然后是一个m,接着是m行查询,要问这n个数从小到大的第i个数是多少(1<=n<=100000,1<=k<=100)
Input
第一行为一个整数n表示数列长度,之后n行为n个数,然后用一行###隔开,之后是一个整数m表示查询次数,然后是m个数表示查询
Output
对于每次查询,输出数列中第i小的数
Sample Input
5
7
121
123
7
121
###
4
3
3
2
5
Sample Output
121
121
7
123
Solution
水题
Code

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
#define INF (1<<29)
#define maxn 100005
int num[maxn];
int n,m;
int main()
{
    char s[10];
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d",&num[i]);
    sort(num,num+n);
    scanf("%s",s);
    scanf("%d",&m);
    while(m--)
    {
        int d;
        scanf("%d",&d);
        printf("%d\n",num[d-1]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值