hdu--1973 Prime Path

题目链接

Prime Path
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033 
1733 
3733 
3739 
3779 
8779 
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>

using namespace std;

#define N 11000
#define INF 0xfffffff
#define PI acos (-1.0)
#define EPS 1e-8

const int dir[8][2] = {{-1, -1}, {-1, 0}, {-1, 1}, {0, -1}, {0, 1}, {1, -1}, {1, 0}, {1, 1}};

struct node
{
    int x, t;
}qq;

int sa, en, vis[N];
void BFS (int sa, int en);
int isprime (int x);

int main ()
{
    int t;
    cin >> t;
    while (t--)
    {
        cin >> sa >> en;
        BFS (sa, en);
    }
    return 0;
}

void BFS (int sa, int en)
{
    memset (vis, 0, sizeof (vis));
    queue <node> que;
    qq = (node) {sa, 0};
    que.push(qq);
    vis[qq.x] = 1;

    while (que.size())
    {
        qq = que.front(); que.pop();

        if (qq.x == en)
        {
            cout << qq.t << endl;
            return;
        }

        char s1[5], s2[5];
        int tt = qq.x;
        s1[4] = '\0';

        for (int i=3; i>=0; i--)
        {
            s1[i] = tt % 10 + '0';
            tt /= 10;
        }

        for (int i=0; i<4; i++)
        {
            strcpy (s2, s1);
            for (int j=0; j<=9; j++)
            {
                if ((!i && !j) || s2[i] == j + '0')
                    continue;
                s2[i] = j + '0';

                int num = atoi(s2);
                if (num & 1 == 0)
                    continue;
                if (isprime(num) && !vis[num])
                {
                    vis[num] = 1;
                    node q = (node) {num, qq.t+1};
                    que.push(q);
                }
            }
        }
    }
    cout << "Impossible" << endl;
}

int isprime (int x)
{
    for (int i=2; i*i<=x; i++)
        if (x % i == 0)
            return 0;
    return 1;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_大太阳_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值