Prime Path(HDU-1973)

Prime Path

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 646    Accepted Submission(s): 418


Problem Description
The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
—I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don’t know some very cheap software gurus, do you?
—In fact, I do. You see, there is this programming contest going on. . .

Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
 

Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
 

Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
 

Sample Input
  
  
3 1033 8179 1373 8017 1033 1033
 

Sample Output
  
  
6 7 0
 

题目大意:

给两个素数,从第一个素数变化到第二个素数,每次只能改变一个位置上的数,求最小操作步骤。

解题思路:

①使用筛法求素数把10000以内的素数预存。

②千位为0的情况非法,应该忽略。

③枚举时可跳过个位为偶数的情况加快速度(个位为0肯定不是素数)。

④ed数组记录已经出现过的情况避免重复判断。

代码如下:

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
typedef struct Node
{
	int k[4];
	int sum;
}number;
queue<number>q;
void hanshu();
void bfs();
int sushu[10000];
int ed[10000];
int a[4];
int end[4];
int main()
{
	hanshu();
	int n;
	scanf("%d",&n);
	while(n--)
	{
		bfs();
		while(!q.empty())
		q.pop();
	}
	return 0;
}
void bfs()
{
	scanf("%1d%1d%1d%1d",&a[0],&a[1],&a[2],&a[3]);
	scanf("%1d%1d%1d%1d",&end[0],&end[1],&end[2],&end[3]);
	number nb;
	memset(ed,0,sizeof(ed));
	ed[a[0]*1000+a[1]*100+a[2]*10+a[3]] = 1;
	nb.k[0] = a[0];
	nb.k[1] = a[1];
	nb.k[2] = a[2];
	nb.k[3] = a[3];
	nb.sum = 0;
	q.push(nb);
	while(!q.empty())
	{
		nb = q.front();
		q.pop();
		if(nb.k[0] == end[0] && nb.k[1] == end[1] && nb.k[2] == end[2] && nb.k[3] == end[3])
		{
			printf("%d\n",nb.sum);
			return ;
		}
		for(int i=0 ; i<4 ; i++)
		{
			number new_n=nb ;
			new_n.sum++;
			for(int j=0 ; j<10 ; j++)
			{
				new_n.k[i] = j;
				if(i+j==0) continue;
				if(i==4 && j%2) continue;
				if(!ed[new_n.k[0]*1000+new_n.k[1]*100+new_n.k[2]*10+new_n.k[3]] && !sushu[new_n.k[0]*1000+new_n.k[1]*100+new_n.k[2]*10+new_n.k[3]])
				{
					ed[new_n.k[0]*1000+new_n.k[1]*100+new_n.k[2]*10+new_n.k[3]] = 1;
					q.push(new_n);
				}
			}
		}
	}
}
void hanshu()
{
	sushu[0] = 1;
	sushu[1] = 1;
	for(int i=2 ; i<10000 ; i++)
	for(int j=i*i ; j<10000 ; j+=i)
	sushu[j] = 1;
}


题目传送门。。。。。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值